summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2020-07-21 14:27:47 +0200
committerJason A. Donenfeld <zx2c4@gentoo.org>2020-07-21 14:27:47 +0200
commit501a8da9c33723a26d03718598666e45516ff05a (patch)
treed30e8a5a40a8b30228548c07c97d3aaa782f9b18 /net-vpn/wireguard-tools
parentapp-office/gnucash: Bump to 4.0 (diff)
downloadgentoo-501a8da9c33723a26d03718598666e45516ff05a.tar.gz
gentoo-501a8da9c33723a26d03718598666e45516ff05a.tar.bz2
gentoo-501a8da9c33723a26d03718598666e45516ff05a.zip
net-vpn/wireguard-tools: drop old
Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
Diffstat (limited to 'net-vpn/wireguard-tools')
-rw-r--r--net-vpn/wireguard-tools/Manifest1
-rw-r--r--net-vpn/wireguard-tools/wireguard-tools-1.0.20200319.ebuild101
2 files changed, 0 insertions, 102 deletions
diff --git a/net-vpn/wireguard-tools/Manifest b/net-vpn/wireguard-tools/Manifest
index bf04b880791b..b60ce915a977 100644
--- a/net-vpn/wireguard-tools/Manifest
+++ b/net-vpn/wireguard-tools/Manifest
@@ -1,2 +1 @@
-DIST wireguard-tools-1.0.20200319.tar.xz 92324 BLAKE2B 9f514748708ef6a5b7f5b043c9054c954d17bb77de7a354b5a9a4e63cfb5f441237e98b16b288426441a7e709e1874d396cf67b04b38bb0ebbe7822bb32ada57 SHA512 d5bcd153f9b10f184b9a1bf9a81f33a9713ab4863ab5aa190eac60e92919756c8fecbb0d3cfb83bae20ac78fc43fdd7168f37294cdd7c5ee21f2a1b2db5fdf41
DIST wireguard-tools-1.0.20200513.tar.xz 94500 BLAKE2B 34a39533018416df382d180da76d6494feec1d40208c9df427c1979817dbe138c217fe4c4f4cf5cecd3c4053e6f73f1863d1e0a9ed2cad41899dda5387c15844 SHA512 4d27b262350b6b47843a323c2e7ab8d2bdd48065c265778abdec85b3f6fc92aa9af77d76e368df9cc8e435eae1c0ce50fed52e1d78db54358c1884d34be08d2c
diff --git a/net-vpn/wireguard-tools/wireguard-tools-1.0.20200319.ebuild b/net-vpn/wireguard-tools/wireguard-tools-1.0.20200319.ebuild
deleted file mode 100644
index 07fee8d91012..000000000000
--- a/net-vpn/wireguard-tools/wireguard-tools-1.0.20200319.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit linux-info bash-completion-r1 systemd toolchain-funcs
-
-DESCRIPTION="Required tools for WireGuard, such as wg(8) and wg-quick(8)"
-HOMEPAGE="https://www.wireguard.com/"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://git.zx2c4.com/wireguard-tools"
-else
- SRC_URI="https://git.zx2c4.com/wireguard-tools/snapshot/wireguard-tools-${PV}.tar.xz"
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="+wg-quick"
-
-BDEPEND="virtual/pkgconfig"
-DEPEND=""
-RDEPEND="${DEPEND}
- wg-quick? (
- || ( net-firewall/nftables net-firewall/iptables )
- virtual/resolvconf
- )
- !<virtual/wireguard-1
-"
-
-wg_quick_optional_config_nob() {
- CONFIG_CHECK="$CONFIG_CHECK ~$1"
- declare -g ERROR_$1="CONFIG_$1: This option is required for automatic routing of default routes inside of wg-quick(8), though it is not required for general WireGuard usage."
-}
-
-pkg_setup() {
- use wg-quick || return 0
- wg_quick_optional_config_nob IP_ADVANCED_ROUTER
- wg_quick_optional_config_nob IP_MULTIPLE_TABLES
- wg_quick_optional_config_nob IPV6_MULTIPLE_TABLES
- if has_version net-firewall/nftables; then
- wg_quick_optional_config_nob NF_TABLES
- wg_quick_optional_config_nob NF_TABLES_IPV4
- wg_quick_optional_config_nob NF_TABLES_IPV6
- wg_quick_optional_config_nob NFT_CT
- wg_quick_optional_config_nob NFT_FIB
- wg_quick_optional_config_nob NFT_FIB_IPV4
- wg_quick_optional_config_nob NFT_FIB_IPV6
- wg_quick_optional_config_nob NF_CONNTRACK_MARK
- elif has_version net-firewall/iptables; then
- wg_quick_optional_config_nob NETFILTER_XTABLES
- wg_quick_optional_config_nob NETFILTER_XT_MARK
- wg_quick_optional_config_nob NETFILTER_XT_CONNMARK
- wg_quick_optional_config_nob NETFILTER_XT_MATCH_COMMENT
- wg_quick_optional_config_nob NETFILTER_XT_MATCH_ADDRTYPE
- wg_quick_optional_config_nob IP6_NF_RAW
- wg_quick_optional_config_nob IP_NF_RAW
- wg_quick_optional_config_nob IP6_NF_FILTER
- wg_quick_optional_config_nob IP_NF_FILTER
- fi
- linux-info_pkg_setup
-}
-
-src_compile() {
- emake RUNSTATEDIR="${EPREFIX}/run" -C src CC="$(tc-getCC)" LD="$(tc-getLD)"
-}
-
-src_install() {
- dodoc README.md
- dodoc -r contrib
- emake \
- WITH_BASHCOMPLETION=yes \
- WITH_SYSTEMDUNITS=yes \
- WITH_WGQUICK=$(usex wg-quick) \
- DESTDIR="${D}" \
- BASHCOMPDIR="$(get_bashcompdir)" \
- SYSTEMDUNITDIR="$(systemd_get_systemunitdir)" \
- PREFIX="${EPREFIX}/usr" \
- -C src install
-}
-
-pkg_postinst() {
- einfo
- einfo "After installing WireGuard, if you'd like to try sending some packets through"
- einfo "WireGuard, you may use, for testing purposes only, the insecure client.sh"
- einfo "test example script:"
- einfo
- einfo " \$ bzcat ${ROOT}/usr/share/doc/${PF}/contrib/ncat-client-server/client.sh.bz2 | sudo bash -"
- einfo
- einfo "This will automatically setup interface wg0, through a very insecure transport"
- einfo "that is only suitable for demonstration purposes. You can then try loading the"
- einfo "hidden website or sending pings:"
- einfo
- einfo " \$ chromium http://192.168.4.1"
- einfo " \$ ping 192.168.4.1"
- einfo
- einfo "More info on getting started can be found at: https://www.wireguard.com/quickstart/"
- einfo
-}