summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-04-21 11:40:51 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-04-21 11:41:19 -0500
commita60447b3cc387cf77bec720d8ce3bb43b124582b (patch)
treea738477b4efd63fbb34b1d5e5ee2ed5b4c50d9b6 /net-vpn
parentdev-libs/libclc: Stabilize 13.0.1 x86, #833209 (diff)
downloadgentoo-a60447b3cc387cf77bec720d8ce3bb43b124582b.tar.gz
gentoo-a60447b3cc387cf77bec720d8ce3bb43b124582b.tar.bz2
gentoo-a60447b3cc387cf77bec720d8ce3bb43b124582b.zip
net-vpn/tailscale: add 1.22.2
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/tailscale/Manifest2
-rw-r--r--net-vpn/tailscale/tailscale-1.22.2.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/net-vpn/tailscale/Manifest b/net-vpn/tailscale/Manifest
index eb7beedb0bfd..e07048e584fd 100644
--- a/net-vpn/tailscale/Manifest
+++ b/net-vpn/tailscale/Manifest
@@ -1995,3 +1995,5 @@ DIST tailscale-1.18.1.tar.gz 891341 BLAKE2B acefe5108f0fca360afd48f2a4acb72fc92c
DIST tailscale-1.20.3.tar.gz 976671 BLAKE2B 11ff33dfd67d0bc902f965a28c8916d3b813dda57658806f702e664b8ade29e6dcb75ffdaf4b0bf1a80ad79fcf7876a1ddf1e8e031697bf990d40256ec63b6e4 SHA512 f99185ee4d0c2d688992fae1c734d8d8793ff1868f47089d3e850477ad274fa00a1bc0e5afb26455de34bba1c4a592b9532e278ba651f26ecc97248c912ed713
DIST tailscale-1.22.0-vendor.tar.xz 5861668 BLAKE2B 0ccc953e7fa20fd13a6582e10864ff15dee15bc8991ad27439a771d05a13d4be7c11e2bdde6a4c19ad745fdf7d2bbf31c3e44513df1cf634c5a0842e243221db SHA512 7e7a8027aa8c17f74ec6c7ccdc6b79113820a9a106c23c8d8fbb5da17fe97ef9abd70dd66363d6abc0619f26f2fb889066fd8dd1cef18295c4dbc34072e08c3d
DIST tailscale-1.22.0.tar.gz 1018528 BLAKE2B 1ae5a4d76f6f097d85789f875624bae10d146c1503d6d96dc20f85b190ec5586c25c78d5503fb1ac839f6d547379a8ad934bffe0a1a7f76843b643d596aac24f SHA512 d5476d5bac50c0789d0718f39ffee1fb7299f74e6d2682e61fd7856bb63811f2f245c1e10c7befae34b075231210d79fdbde53d24ceba77ed106f8040aab4bcc
+DIST tailscale-1.22.2-deps.tar.xz 109072196 BLAKE2B 6cd0b6d1f81ae47815e6ba924da3f8f978e7cc70ce1fa6044b2e12474d07a910d3de73d8005985ce90ebbc304cae0128da61e06871a09b78e5862f2d37c5709c SHA512 31dcb82afa2f75b9513b9a01545d6416218be110ad3350e434cb9c1296da2d7e8793dd55e2269b0ad79ada4174d2e334dcac03f669494ce39fd071dc57bb72b1
+DIST tailscale-1.22.2.tar.gz 1019987 BLAKE2B 41911754239944a51e5da9f98392452ad0f28b223423cb2a1b76031cf4f6fb78c4bbcf11efd4b3b257625d66c8c14380cafafb532278a0f6bf306e072326839f SHA512 5aeb2d2881023d1e0cb62a02ac0f3cf931765d2e8674883ccc863c52da7eb3d2f08903556ea0a3679fa404519244a65c9b1df99066c4167402d7e688ca256035
diff --git a/net-vpn/tailscale/tailscale-1.22.2.ebuild b/net-vpn/tailscale/tailscale-1.22.2.ebuild
new file mode 100644
index 000000000000..4a326607d92b
--- /dev/null
+++ b/net-vpn/tailscale/tailscale-1.22.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# These settings are obtained by running ./build_dist.sh shellvars` in
+# the upstream repo.
+VERSION_MINOR="1.22"
+VERSION_SHORT="1.22.2"
+VERSION_LONG="1.22.2-t6f700925c"
+VERSION_GIT_HASH="6f700925cef22d8b2a100840c8d9eb084dadfece"
+
+DESCRIPTION="Tailscale vpn client"
+HOMEPAGE="https://tailscale.com"
+SRC_URI="https://github.com/tailscale/tailscale/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="net-firewall/iptables"
+
+# This translates the build command from upstream's build_dist.sh to an
+# ebuild equivalent.
+build_dist() {
+ ego build -tags xversion -ldflags "
+ -X tailscale.com/version.Long=${VERSION_LONG}
+ -X tailscale.com/version.Short=${VERSION_SHORT}
+ -X tailscale.com/version.GitCommit=${VERSION_GIT_HASH}" "$@"
+}
+
+src_compile() {
+ build_dist ./cmd/tailscale
+ build_dist ./cmd/tailscaled
+}
+
+src_install() {
+ dosbin tailscaled
+ dobin tailscale
+
+ systemd_dounit cmd/tailscaled/tailscaled.service
+ insinto /etc/default
+ newins cmd/tailscaled/tailscaled.defaults tailscaled
+ keepdir /var/lib/${PN}
+ fperms 0750 /var/lib/${PN}
+
+ newtmpfiles "${FILESDIR}/${PN}.tmpfiles" ${PN}.conf
+
+ newinitd "${FILESDIR}/${PN}d.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}d.confd" ${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+}