summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2019-04-13 18:35:46 +0200
committerTiziano Müller <dev-zero@gentoo.org>2019-04-13 18:37:52 +0200
commit697e3c0695aa214f2734434077326f929456ac19 (patch)
treecf9284f4a7ebb5673275b5110b28a5870c174929 /net-wireless/blueman/blueman-9999.ebuild
parentprofiles: Mask app-emacs/prom-wl for removal. (diff)
downloadgentoo-697e3c0695aa214f2734434077326f929456ac19.tar.gz
gentoo-697e3c0695aa214f2734434077326f929456ac19.tar.bz2
gentoo-697e3c0695aa214f2734434077326f929456ac19.zip
net-wireless/blueman: fix DHCP server dir & kernel config check
Closes: https://bugs.gentoo.org/596634 Closes: https://bugs.gentoo.org/628924 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Tiziano Müller <dev-zero@gentoo.org>
Diffstat (limited to 'net-wireless/blueman/blueman-9999.ebuild')
-rw-r--r--net-wireless/blueman/blueman-9999.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/net-wireless/blueman/blueman-9999.ebuild b/net-wireless/blueman/blueman-9999.ebuild
index c05adb445a66..d7fc408394e5 100644
--- a/net-wireless/blueman/blueman-9999.ebuild
+++ b/net-wireless/blueman/blueman-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
-PYTHON_COMPAT=( python{3_4,3_5,3_6,3_7} )
+PYTHON_COMPAT=( python3_{5,6,7} )
inherit gnome2-utils linux-info python-single-r1 systemd
DESCRIPTION="Simple and intuitive GTK+ Bluetooth Manager"
@@ -14,7 +14,7 @@ if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/blueman-project/blueman.git"
KEYWORDS=""
else
- SRC_URI="https://github.com/blueman-project/${PN}/releases/download/${PV}/${P}.tar.xz"
+ SRC_URI="https://github.com/blueman-project/${PN}/releases/download/${PV/_/.}/${P/_/.}.tar.xz"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
fi
@@ -22,15 +22,15 @@ LICENSE="GPL-3"
SLOT="0"
IUSE="appindicator network nls policykit pulseaudio"
-COMMON_DEPEND="
+DEPEND="
dev-python/pygobject:3[${PYTHON_USEDEP}]
>=net-wireless/bluez-5:=
${PYTHON_DEPS}"
-DEPEND="${COMMON_DEPEND}
+BDEPEND="
dev-python/cython[${PYTHON_USEDEP}]
virtual/pkgconfig
nls? ( dev-util/intltool sys-devel/gettext )"
-RDEPEND="${COMMON_DEPEND}
+RDEPEND="${DEPEND}
dev-python/dbus-python[${PYTHON_USEDEP}]
dev-python/pycairo[${PYTHON_USEDEP}]
sys-apps/dbus
@@ -65,12 +65,11 @@ pkg_pretend() {
if use network; then
local CONFIG_CHECK="~BRIDGE ~IP_NF_IPTABLES
~IP_NF_NAT ~IP_NF_TARGET_MASQUERADE"
- linux-info_pkg_setup
+ check_extra_config
fi
}
pkg_setup() {
- pkg_pretend
python-single-r1_pkg_setup
}
@@ -86,6 +85,7 @@ src_configure() {
--disable-static
--with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
--with-systemduserunitdir="$(systemd_get_userunitdir)"
+ --with-dhcp-config="/etc/dhcp/dhcpd.conf"
$(use_enable appindicator)
$(use_enable policykit polkit)
$(use_enable nls)