summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-01 12:10:27 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-01 13:06:56 +0200
commitb5d1ed74673f8e4c78565334ce8102a10be0f460 (patch)
treef7ef36d433b4c8e1a69067c6c0ad841342db8e2c /net-wireless/blueman/blueman-9999.ebuild
parentdev-python/apsw: Bump to 3.39.2.0 (diff)
downloadgentoo-b5d1ed74673f8e4c78565334ce8102a10be0f460.tar.gz
gentoo-b5d1ed74673f8e4c78565334ce8102a10be0f460.tar.bz2
gentoo-b5d1ed74673f8e4c78565334ce8102a10be0f460.zip
net-wireless/blueman: Bump to 2.3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-wireless/blueman/blueman-9999.ebuild')
-rw-r--r--net-wireless/blueman/blueman-9999.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/net-wireless/blueman/blueman-9999.ebuild b/net-wireless/blueman/blueman-9999.ebuild
index dbedcfc7eae6..453fb6b604da 100644
--- a/net-wireless/blueman/blueman-9999.ebuild
+++ b/net-wireless/blueman/blueman-9999.ebuild
@@ -7,13 +7,13 @@ DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_PEP517=no
PYTHON_COMPAT=( python3_{8..11} )
-inherit autotools distutils-r1 gnome2-utils linux-info systemd xdg-utils
+inherit distutils-r1 gnome2-utils linux-info systemd xdg-utils
DESCRIPTION="Simple and intuitive GTK+ Bluetooth Manager"
HOMEPAGE="https://github.com/blueman-project/blueman/"
if [[ ${PV} == "9999" ]] ; then
- inherit git-r3
+ inherit autotools git-r3
EGIT_REPO_URI="https://github.com/blueman-project/blueman.git"
else
SRC_URI="
@@ -64,7 +64,7 @@ RDEPEND="
|| (
net-dns/dnsmasq
net-misc/dhcp
- >=net-misc/networkmanager-0.8
+ >=net-misc/networkmanager-0.8[introspection]
)
)
policykit? (
@@ -118,6 +118,16 @@ python_configure() {
econf "${myconf[@]}"
}
+python_compile() {
+ default
+}
+
+python_test() {
+ # import tests are not very valuable and fail if /dev/rfkill
+ # does not exist
+ "${EPYTHON}" -m unittest -v test/test_gobject.py || die
+}
+
python_install() {
default