summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-01 01:11:17 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-07 23:59:54 +0100
commitd1fc92b9467515ccbd0c04cdd56f3508013763da (patch)
treee633ea7b2f457d773f0347574249b9e3c14a1058 /net-wireless
parentnet-wireless/gr-baz: EAPI-7 bump (diff)
downloadgentoo-d1fc92b9467515ccbd0c04cdd56f3508013763da.tar.gz
gentoo-d1fc92b9467515ccbd0c04cdd56f3508013763da.tar.bz2
gentoo-d1fc92b9467515ccbd0c04cdd56f3508013763da.zip
net-wireless/gr-paint: EAPI-7 bump
Capital DESCRIPTION Indentation Sort DEPENDs Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/gr-paint/gr-paint-9999.ebuild41
1 files changed, 23 insertions, 18 deletions
diff --git a/net-wireless/gr-paint/gr-paint-9999.ebuild b/net-wireless/gr-paint/gr-paint-9999.ebuild
index 730dd1b13717..e61888f8ab75 100644
--- a/net-wireless/gr-paint/gr-paint-9999.ebuild
+++ b/net-wireless/gr-paint/gr-paint-9999.ebuild
@@ -1,39 +1,44 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
PYTHON_COMPAT=( python2_7 )
-inherit git-r3
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/drmpeg/gr-paint.git"
+else
+ KEYWORDS=""
+fi
inherit cmake-utils python-single-r1
-DESCRIPTION="paints monochrome images into the waterfall of a receiver"
+DESCRIPTION="Paints monochrome images into the waterfall of a receiver"
HOMEPAGE="https://github.com/drmpeg/gr-paint"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/drmpeg/gr-paint.git"
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS=""
IUSE="doc"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-COMMON_DEPEND="${PYTHON_DEPS}
- net-wireless/gnuradio:=[${PYTHON_USEDEP}]
- dev-libs/boost:=[${PYTHON_USEDEP}]"
-RDEPEND="${COMMON_DEPEND}
- media-gfx/imagemagick"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
- dev-util/cppunit
+DEPEND="${PYTHON_DEPS}
+ dev-libs/boost:=[${PYTHON_USEDEP}]
+ net-wireless/gnuradio:=[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}
+ media-gfx/imagemagick
+"
+BDEPEND="
dev-lang/swig
- doc? ( app-doc/doxygen )"
+ dev-util/cppunit
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
src_configure() {
- mycmakeargs=(
- $(cmake-utils_use_enable doc DOXYGEN)
+ local mycmakeargs=(
+ -DENABLE_DOXYGEN=$(usex doc)
-DPYTHON_EXECUTABLE="${PYTHON}"
)
cmake-utils_src_configure