summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-20 03:41:31 +0100
committerSam James <sam@gentoo.org>2023-07-20 03:41:31 +0100
commite2eb4c9bdeeaa100a2375a895a9c45f34481bc2e (patch)
tree36fc171a3cdba2269f70754c7c45e0210753b0f8 /perl-core
parentdev-perl/XS-Parse-Keyword: add 0.350.0 (diff)
downloadgentoo-e2eb4c9bdeeaa100a2375a895a9c45f34481bc2e.tar.gz
gentoo-e2eb4c9bdeeaa100a2375a895a9c45f34481bc2e.tar.bz2
gentoo-e2eb4c9bdeeaa100a2375a895a9c45f34481bc2e.zip
perl-core/Compress-Raw-Zlib: add 2.205.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'perl-core')
-rw-r--r--perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.205.0.ebuild31
-rw-r--r--perl-core/Compress-Raw-Zlib/Manifest1
2 files changed, 32 insertions, 0 deletions
diff --git a/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.205.0.ebuild b/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.205.0.ebuild
new file mode 100644
index 000000000000..f2caaf12c552
--- /dev/null
+++ b/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.205.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=PMQS
+DIST_TEST=parallel
+DIST_VERSION=2.205
+inherit perl-module
+
+DESCRIPTION="Low-Level Interface to zlib compression library"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+# We use the bundled version of zlib as the minimum version for the system copy
+# Check on bumps! Look in https://github.com/pmqs/Compress-Raw-Zlib/commits/master/zlib-src.
+RDEPEND=">=sys-libs/zlib-1.2.13"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/perl-ExtUtils-MakeMaker"
+
+src_prepare() {
+ rm -rf "${S}"/zlib-src/ || die
+ sed -i '/^zlib-src/d' "${S}"/MANIFEST || die
+ perl-module_src_prepare
+}
+
+src_configure() {
+ BUILD_ZLIB=False ZLIB_INCLUDE="${ESYSROOT}"/usr/include \
+ ZLIB_LIB="${ESYSROOT}"/usr/$(get_libdir) perl-module_src_configure
+}
diff --git a/perl-core/Compress-Raw-Zlib/Manifest b/perl-core/Compress-Raw-Zlib/Manifest
index 21b5c715bb69..e63eb55cfe65 100644
--- a/perl-core/Compress-Raw-Zlib/Manifest
+++ b/perl-core/Compress-Raw-Zlib/Manifest
@@ -1 +1,2 @@
DIST Compress-Raw-Zlib-2.202.tar.gz 480563 BLAKE2B 8e9eef5fae7dcac500b08ee7315e6d05912fe954e18560f1ecc195800343102cd0f97690c46c5e06bc6c734877e48356cb93fa70d7070c954e62dc2a7bd2d6c5 SHA512 add25f83ecd83fe3beaad12a6f8b37ca046fdfccfa44c03f32b104a9ec6c132407dc606ba0e30fad67151f1b1d4f6886991b19948c12e2964df13a6daa703e72
+DIST Compress-Raw-Zlib-2.205.tar.gz 481904 BLAKE2B 19572f48b1f25a901b1a88ad49d40ed0a57361f5f62870cce11dc85069e86695db6c3206101c2cd3609e2acb598799ce0a124f1b950cab901bfc412fed5e8580 SHA512 567abb51dc9939f0e0bc206202e63cd8805f924ef23ca48eae4992fdf97d58167aa7438732abd4cd27fa83b3849c7b263b55f3ec10009dddab8c9ca0d1a0ec18