summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-11-29 20:20:59 +0100
committerMarek Szuba <marecki@gentoo.org>2020-11-29 20:41:58 +0100
commit1e16f00ebe854302532ed3d504e33062bd17afe8 (patch)
tree6aa80c7e83937ed965ec52306eb853fb81b147b7 /sci-astronomy/celestia/files
parentsci-libs/plplot: migrate to lua-single.eclass (diff)
downloadgentoo-1e16f00ebe854302532ed3d504e33062bd17afe8.tar.gz
gentoo-1e16f00ebe854302532ed3d504e33062bd17afe8.tar.bz2
gentoo-1e16f00ebe854302532ed3d504e33062bd17afe8.zip
sci-astronomy/celestia: migrate to lua-single.eclass
Both the release and the live ebuild. Closes: https://bugs.gentoo.org/752828 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'sci-astronomy/celestia/files')
-rw-r--r--sci-astronomy/celestia/files/celestia-1.7.0-cmake_lua_version.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/sci-astronomy/celestia/files/celestia-1.7.0-cmake_lua_version.patch b/sci-astronomy/celestia/files/celestia-1.7.0-cmake_lua_version.patch
new file mode 100644
index 000000000000..80fba5d447a4
--- /dev/null
+++ b/sci-astronomy/celestia/files/celestia-1.7.0-cmake_lua_version.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -179,7 +179,7 @@
+
+ find_package(LuaJIT)
+ if(NOT LUAJIT_FOUND)
+- find_package(Lua REQUIRED)
++ find_package(Lua ${LUA_VERSION} EXACT REQUIRED)
+ endif()
+ include_directories(${LUA_INCLUDE_DIR})
+ link_libraries(${LUA_LIBRARIES})