summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-19 23:58:33 -0400
committerSam James <sam@gentoo.org>2024-03-20 06:17:03 +0000
commitc33c578e0eaeda556d7b5467fce0e97726c0d8f5 (patch)
treea9e432624968e2fbe6609e489e127697d9536657 /sci-biology
parentmedia-libs/nas: mark as LTO-unsafe (diff)
downloadgentoo-c33c578e0eaeda556d7b5467fce0e97726c0d8f5.tar.gz
gentoo-c33c578e0eaeda556d7b5467fce0e97726c0d8f5.tar.bz2
gentoo-c33c578e0eaeda556d7b5467fce0e97726c0d8f5.zip
sci-biology/muscle: mark as LTO-unsafe, strict-aliasing unsafe
Closes: https://bugs.gentoo.org/862276 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/muscle/muscle-3.8.31.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/sci-biology/muscle/muscle-3.8.31.ebuild b/sci-biology/muscle/muscle-3.8.31.ebuild
index e47f5f66cf46..faefc5b1a280 100644
--- a/sci-biology/muscle/muscle-3.8.31.ebuild
+++ b/sci-biology/muscle/muscle-3.8.31.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
MY_P="${PN}${PV}_src"
@@ -22,6 +22,14 @@ S="${WORKDIR}"/${PN}${PV}/src
PATCHES=( "${FILESDIR}"/${PV}-make.patch )
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/862276
+ # Fixed upstream in later releases
+ #
+ # Do not trust with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
tc-export CXX
}