summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-11-24 10:52:41 +0200
committerViorel Munteanu <ceamac@gentoo.org>2024-11-24 13:21:16 +0200
commit4ac010dc31052b2613d65002caf05e0ffe52bd3e (patch)
tree3b4093308d9f04b6c982cc2d31c952f9ba3b8a3e /sci-calculators
parentdev-ruby/excon: add 1.2.1 (diff)
downloadgentoo-4ac010dc31052b2613d65002caf05e0ffe52bd3e.tar.gz
gentoo-4ac010dc31052b2613d65002caf05e0ffe52bd3e.tar.bz2
gentoo-4ac010dc31052b2613d65002caf05e0ffe52bd3e.zip
sci-calculators/units: don't build with C23
Don't build with C23. Also remove a sed command that was doing nothing (qa-sed). Closes: https://bugs.gentoo.org/944371 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/units/units-2.23-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/sci-calculators/units/units-2.23-r1.ebuild b/sci-calculators/units/units-2.23-r1.ebuild
new file mode 100644
index 000000000000..182f80f63d90
--- /dev/null
+++ b/sci-calculators/units/units-2.23-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit flag-o-matic python-r1
+
+DESCRIPTION="Unit conversion program"
+HOMEPAGE="https://www.gnu.org/software/units/units.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="FDL-1.3 GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+units-cur"
+REQUIRED_USE="units-cur? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ sys-libs/readline:=
+ units-cur? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/requests[${PYTHON_USEDEP}]
+ ')
+ )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.20-readerror.patch
+)
+
+DOCS=( NEWS README )
+
+src_configure() {
+ # bug #944371
+ append-cflags -std=gnu17
+
+ local myconf=(
+ --sharedstatedir="${EPREFIX}"/var/lib
+ ac_cv_path_PYTHON=no
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ emake ${PN}
+}
+
+src_install() {
+ default
+
+ if use units-cur; then
+ sed \
+ -e 's|^#!|&/usr/bin/python|g' \
+ units_cur_inst > units_cur || die
+ python_foreach_impl python_doscript units_cur
+ fi
+}