summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2024-03-05 13:56:54 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2024-03-26 13:53:06 +0300
commitc2eae57dd0815a47e8c59e0c6dbcda1eea67f949 (patch)
treef96b9ca64b81ea8d6762a420d8f41c2fdf59ea10 /sci-chemistry/autodock_vina/autodock_vina-1.2.5.ebuild
parentdev-python/isort: Deselect failing tests (diff)
downloadgentoo-c2eae57dd0815a47e8c59e0c6dbcda1eea67f949.tar.gz
gentoo-c2eae57dd0815a47e8c59e0c6dbcda1eea67f949.tar.bz2
gentoo-c2eae57dd0815a47e8c59e0c6dbcda1eea67f949.zip
sci-chemistry/autodock_vina: add 1.2.5
Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'sci-chemistry/autodock_vina/autodock_vina-1.2.5.ebuild')
-rw-r--r--sci-chemistry/autodock_vina/autodock_vina-1.2.5.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sci-chemistry/autodock_vina/autodock_vina-1.2.5.ebuild b/sci-chemistry/autodock_vina/autodock_vina-1.2.5.ebuild
new file mode 100644
index 000000000000..e9edf1f9c991
--- /dev/null
+++ b/sci-chemistry/autodock_vina/autodock_vina-1.2.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+MY_PN=AutoDock-Vina
+
+DESCRIPTION="Program for drug discovery, molecular docking and virtual screening"
+HOMEPAGE="http://vina.scripps.edu/"
+SRC_URI="https://github.com/ccsb-scripps/AutoDock-Vina/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/${MY_PN}-${PV}/build/linux/release"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="dev-libs/boost:="
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+)
+
+src_prepare() {
+ cd "${WORKDIR}/${MY_PN}-${PV}" || die
+ pwd
+ sed -e "s:VERSION:\"${PV}\":g" \
+ -i src/main/main.cpp \
+ -i src/split/split.cpp || die
+ default
+}
+
+src_configure() {
+ append-cxxflags -DBOOST_FILESYSTEM_VERSION=3 -DBOOST_TIMER_ENABLE_DEPRECATED -std=c++14
+}
+
+src_compile() {
+ emake \
+ BASE="${EPREFIX}"/usr/ \
+ GPP="$(tc-getCXX)" \
+ C_OPTIONS=$(usex debug '' -DNDEBUG)
+}
+
+src_install() {
+ dobin vina{,_split}
+}