summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <markus.meier74@gmail.com>2024-07-05 16:56:12 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-07-05 16:56:12 +0300
commit815238afdd1e233c2e4bc8eaf284108853b49b36 (patch)
tree6ba29d4f1703a861871ef5e9ec75b7ef4e39cd9a /sci-chemistry
parentmedia-video/luvcview: last-rite (diff)
downloadgentoo-815238afdd1e233c2e4bc8eaf284108853b49b36.tar.gz
gentoo-815238afdd1e233c2e4bc8eaf284108853b49b36.tar.bz2
gentoo-815238afdd1e233c2e4bc8eaf284108853b49b36.zip
sci-chemistry/xds-bin: add 20240831
Bug: https://bugs.gentoo.org/934365 Authored-by: Markus Meier <markus.meier74@gmail.com> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/xds-bin/Manifest4
-rw-r--r--sci-chemistry/xds-bin/xds-bin-20240831.ebuild56
2 files changed, 59 insertions, 1 deletions
diff --git a/sci-chemistry/xds-bin/Manifest b/sci-chemistry/xds-bin/Manifest
index ac4cfebc4b6f..47908d7ebfbe 100644
--- a/sci-chemistry/xds-bin/Manifest
+++ b/sci-chemistry/xds-bin/Manifest
@@ -1,2 +1,4 @@
-DIST XDS-INTEL64_Linux_x86_64-20170930.tar.gz 9501598 BLAKE2B 33eea09210e9196859f62e66770aef3b34ace7d0cbe50607ef03ba37943fdb13ddf570b53cb2a7e668e650284ff245767a9cca9f6595de9fdb1815bb9625b56e SHA512 8da1d75633e8bf8495c30926a622f57aa0a51ea3b724101c96da6fae0a303860a4a4a8eaf3ecdf66948f18e702211aab3800760ca498c4562e947e3f94c25a4d
DIST XDS_html_doc-20170930.tar.gz 117249 BLAKE2B 81e0c216eee38f21acc4dba299a20c4790f4aa1dc58e2d0dab5474784bf01842db41ab869b6d36cdfc9a31771e0bcad41b062bbf000771552c7de36f36a2291e SHA512 bbc24eeb0f8a63e6186906b0c0ee67efa83d1cdd169b091878c323455e2448ee6cb1667467bc9701b4e1839af2d10d4cb3e8f8d080b7dd5e449fda03c2aa8f89
+DIST XDS_html_doc-20240831.tar.gz 151503 BLAKE2B c559d1a7b4ca75b00d5d37d2c9248fea177cca6a2dac5a9b42443430477337f8bc99add4f89f9eac2d57592b6b5843e167d4e86c6c3ce0ccbb5ba91234d534d8 SHA512 5d3a20dd0b6458c5bfd8ed46f4963fd53f59208fff72278acac19237c988537bae9d7b3c993342c8a9abc03e2ab5aed98a002caeb853fb87c19ae19a32f05faa
+DIST XDS-INTEL64_Linux_x86_64-20170930.tar.gz 9501598 BLAKE2B 33eea09210e9196859f62e66770aef3b34ace7d0cbe50607ef03ba37943fdb13ddf570b53cb2a7e668e650284ff245767a9cca9f6595de9fdb1815bb9625b56e SHA512 8da1d75633e8bf8495c30926a622f57aa0a51ea3b724101c96da6fae0a303860a4a4a8eaf3ecdf66948f18e702211aab3800760ca498c4562e947e3f94c25a4d
+DIST XDS-INTEL64_Linux_x86_64-20240831.tar.gz 11067644 BLAKE2B d8687af54aad5694937cc633f511766147bb52616a388f03d0d052239a0f81b6e3692be0f234ea012905c89e13f2ef45e0254babe1e23598d954b2e65ed93d20 SHA512 773f074237311c8ea2d6dda974250cf906f84db02589bb40b646ff77afac2ee7d978d272993ab5f9b9f55c9dde7965b8e4fba7222349bf3665679f90ec6ef658
diff --git a/sci-chemistry/xds-bin/xds-bin-20240831.ebuild b/sci-chemistry/xds-bin/xds-bin-20240831.ebuild
new file mode 100644
index 000000000000..4fcd833d3071
--- /dev/null
+++ b/sci-chemistry/xds-bin/xds-bin-20240831.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Software for processing single-crystal X-ray monochromatic diffraction data"
+HOMEPAGE="https://xds.mr.mpg.de"
+SRC_URI="
+ https://xds.mr.mpg.de/XDS-INTEL64_Linux_x86_64.tar.gz -> XDS-INTEL64_Linux_x86_64-${PVR}.tar.gz
+ https://xds.mr.mpg.de/XDS_html_doc.tar.gz -> XDS_html_doc-${PVR}.tar.gz"
+
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="smp"
+RESTRICT="fetch"
+
+QA_PREBUILT="opt/xds-bin/*"
+
+# The web site uses a certificate that is not in the system certificate store.
+# Use a web browser to download, instead.
+pkg_nofetch() {
+ elog "Please visit"
+ elog "https://xds.mr.mpg.de/html_doc/downloading.html"
+ elog "and download XDS-INTEL64_Linux_x86_64.tar.gz and XDS_html_doc.tar.gz."
+ elog "Please save them as: ${A}. in your \${DISTDIR}"
+}
+
+src_unpack() {
+ default
+ mv XDS-* "${S}" || die
+}
+
+src_install() {
+ local HTML_DOCS=( "${WORKDIR}"/XDS_html_doc/. )
+ einstalldocs
+
+ local i suffix=$(usex smp '_par' '')
+ exeinto /opt/${PN}
+ doexe *
+
+ for i in xds mintegrate mcolspot xscale; do
+ dosym ../${PN}/${i}${suffix} /opt/bin/${i}
+ done
+
+ for i in 2cbf cellparm forkxds merge2cbf pix2lab xdsconv; do
+ dosym ../${PN}/${i} /opt/bin/${i}
+ done
+
+ insinto /usr/share/${PN}/INPUT_templates
+ doins -r "${WORKDIR}"/XDS_html_doc/html_doc/INPUT_templates/.
+}
+
+pkg_postinst() {
+ elog "This package will expire on August 31, 2024"
+}