summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-09-17 18:09:55 +0200
committerPacho Ramos <pacho@gentoo.org>2023-09-17 18:29:25 +0200
commitdde2c49ecaeccc7ce8fd503f2aa14b2e9247ea5c (patch)
tree795e9bf50913a9c3d0060020b6221c1e5a53193f /sci-chemistry
parentx11-themes/fedora-backgrounds: stabilize 38.1.1 for ALLARCHES (diff)
downloadgentoo-dde2c49ecaeccc7ce8fd503f2aa14b2e9247ea5c.tar.gz
gentoo-dde2c49ecaeccc7ce8fd503f2aa14b2e9247ea5c.tar.bz2
gentoo-dde2c49ecaeccc7ce8fd503f2aa14b2e9247ea5c.zip
sci-chemistry/GromacsWrapper: add 0.8.5
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/GromacsWrapper/GromacsWrapper-0.8.5.ebuild40
-rw-r--r--sci-chemistry/GromacsWrapper/Manifest1
2 files changed, 41 insertions, 0 deletions
diff --git a/sci-chemistry/GromacsWrapper/GromacsWrapper-0.8.5.ebuild b/sci-chemistry/GromacsWrapper/GromacsWrapper-0.8.5.ebuild
new file mode 100644
index 000000000000..e5c508fd6ca1
--- /dev/null
+++ b/sci-chemistry/GromacsWrapper/GromacsWrapper-0.8.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+if [[ ${PV} = *9999* ]]; then
+ scm_eclass=git-r3
+ EGIT_REPO_URI="https://github.com/Becksteinlab/${PN}.git"
+ EGIT_BRANCH="develop"
+ SRC_URI=""
+else
+ scm_eclass=vcs-snapshot
+ SRC_URI="https://github.com/Becksteinlab/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+inherit distutils-r1 ${scm_eclass}
+
+DESCRIPTION="Python framework for Gromacs"
+HOMEPAGE="https://gromacswrapper.readthedocs.io"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ sci-libs/numkit[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( >=dev-python/pandas-0.17[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
diff --git a/sci-chemistry/GromacsWrapper/Manifest b/sci-chemistry/GromacsWrapper/Manifest
index 413b6307fb54..d6ee7a0cfe65 100644
--- a/sci-chemistry/GromacsWrapper/Manifest
+++ b/sci-chemistry/GromacsWrapper/Manifest
@@ -1,2 +1,3 @@
DIST GromacsWrapper-0.8.2.tar.gz 1954926 BLAKE2B c05995667f925a7519e07e59519e985693effa2fd511d228d236bff978d05430d422003e1360f9fda26564e40bb69183ae8e9b7334e0427c2b177f019df38a6a SHA512 b8a3e7da43eaabaf0fe12f4c06ff80f018847f9386c16eb66c96b3840c66b79d02ee47e675c08ed81df0ef495261c3b557d64c62caac0e484f661ef6b3a5be73
DIST GromacsWrapper-0.8.4.tar.gz 1955167 BLAKE2B 59f0301263eefaa4d7c139b34a48172c218a76f0f9488477d6203d9cd732098468dae5a73ff46aa74eb2b4433268c77bc265e506129e4c14a357042453d5f97f SHA512 822edc33c77ca4dbfbc1e4172686744345ed3c0d2305f4b19abab15576a1433bbb3b23b96f637398ad4f72cd5414d96ee531ab4a329d3acb462d90b95437a6a5
+DIST GromacsWrapper-0.8.5.tar.gz 1958570 BLAKE2B b8f79721a7566117206818144fc7087c4634d7fb71c77abef63dd9565a0655ce6b4a259ea5bf9cb3b5bc13df8f428f58e514f7871192d27a6d463e758e27f4b3 SHA512 8800afdbe92edad35df58e825546797ede1738b9029df0fb57a96e377d7be94f3d21fe1df9d5cb4490d12b984972d63d87e673d3d33af60a7dc8d0453574a5c6