summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-11-24 15:00:19 +0100
committerPacho Ramos <pacho@gentoo.org>2023-11-24 15:30:30 +0100
commite9a687ff91dbb21fd84c536ace7f91ce91df32f3 (patch)
treed14ec94db67e9af5da2c83902d1fa108ad641c9a /sci-chemistry
parentsci-chemistry/openbabel: Works with wxGTK 3.2 (diff)
downloadgentoo-e9a687ff91dbb21fd84c536ace7f91ce91df32f3.tar.gz
gentoo-e9a687ff91dbb21fd84c536ace7f91ce91df32f3.tar.bz2
gentoo-e9a687ff91dbb21fd84c536ace7f91ce91df32f3.zip
sci-chemistry/wxmacmolplt: add 7.7.2
Closes: https://bugs.gentoo.org/741366 Closes: https://bugs.gentoo.org/862447 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/wxmacmolplt/Manifest1
-rw-r--r--sci-chemistry/wxmacmolplt/wxmacmolplt-7.7.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/sci-chemistry/wxmacmolplt/Manifest b/sci-chemistry/wxmacmolplt/Manifest
index 0441b389eb6c..57b6c29fc905 100644
--- a/sci-chemistry/wxmacmolplt/Manifest
+++ b/sci-chemistry/wxmacmolplt/Manifest
@@ -1 +1,2 @@
DIST wxmacmolplt-7.5.tar.gz 1965376 BLAKE2B 01033266ae66a215582a62690e792ca4ae82c8a8885fe277e2e77ee67ff70f02f6a9c10467ea6f3cee15933c6c89ba3c6137c9d29e47322ac4f395a3efd41383 SHA512 a1064d5068136b2a91328c7f912ff57d4741081d6d61437e7b4567fbf732917485b391493d637b8892bdad50b539363cfa9c778bb35407a9c0a2bfed20e42bc0
+DIST wxmacmolplt-7.7.2.tar.gz 2012054 BLAKE2B 0e419d9700dd6461a4520722f43cc36cdaa2f51920868a868bdd58db169ed92f88c71d4ce0d79446c4c564eb794f7327b0eef5f87d9ab5a639829287b29482d6 SHA512 bf4b3126bbc8657a604f8dee8b022a17dbf4633a877318ceb45d803456acb0da007c2edae23f581fb6eeafd6ea411d147fbc076acb07aba3dcb8ee55b9c486fa
diff --git a/sci-chemistry/wxmacmolplt/wxmacmolplt-7.7.2.ebuild b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.7.2.ebuild
new file mode 100644
index 000000000000..d233a257b76e
--- /dev/null
+++ b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.7.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.2-gtk3"
+inherit autotools desktop toolchain-funcs wxwidgets
+
+DESCRIPTION="Chemical 3D graphics program with GAMESS input builder"
+HOMEPAGE="http://brettbode.github.io/wxmacmolplt/"
+SRC_URI="https://github.com/brettbode/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/glew:0=
+ media-libs/mesa[X(+)]
+ x11-libs/wxGTK:${WX_GTK_VER}[X,opengl]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ sed \
+ -e "/^dist_doc_DATA/d" \
+ -i Makefile.am || die "Failed to disable installation of LICENSE file"
+ eautoreconf
+}
+
+src_configure() {
+ tc-export PKG_CONFIG
+
+ setup-wxwidgets unicode
+ econf \
+ --with-glew \
+ --without-ming
+}
+
+src_install() {
+ default
+
+ doicon resources/${PN}.png
+ make_desktop_entry ${PN} wxMacMolPlt ${PN} "Science;DataVisualization;"
+}