summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFilip Kobierski <fkobi@pm.me>2024-09-26 16:00:59 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-10-10 15:56:46 +0200
commit6a67915e1fc33aaa3e4f07b5df14cccc4fba677e (patch)
tree1539f57768e531001a92ee46ce901b94e0abd8f6 /sci-electronics
parentwww-client/firefox: add 115.16.1 (diff)
downloadgentoo-6a67915e1fc33aaa3e4f07b5df14cccc4fba677e.tar.gz
gentoo-6a67915e1fc33aaa3e4f07b5df14cccc4fba677e.tar.bz2
gentoo-6a67915e1fc33aaa3e4f07b5df14cccc4fba677e.zip
sci-electronics/gspeakers: bump EAPI & more
- https HOMEPAGE - remove empty IUSE - fix redirection on SRC_URI Signed-off-by: Filip Kobierski <fkobi@pm.me> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/gspeakers/gspeakers-0.11-r3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-electronics/gspeakers/gspeakers-0.11-r3.ebuild b/sci-electronics/gspeakers/gspeakers-0.11-r3.ebuild
new file mode 100644
index 000000000000..15cc964317f5
--- /dev/null
+++ b/sci-electronics/gspeakers/gspeakers-0.11-r3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic gnome2
+
+DESCRIPTION="GTK based loudspeaker enclosure and crossovernetwork designer"
+HOMEPAGE="https://gspeakers.sourceforge.net/"
+SRC_URI="https://downloads.sourceforge.net/project/gspeakers/${PN}/${P}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ dev-cpp/gtkmm:2.4
+ >=dev-libs/libsigc++-2.6:2
+ dev-libs/libxml2:2
+ || (
+ sci-electronics/gnucap
+ sci-electronics/ngspice
+ sci-electronics/spice
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-cxxflags.patch
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-glib-single-include.patch
+ "${FILESDIR}"/${P}-fix-sigc-includes.patch
+ "${FILESDIR}"/${P}-c++11.patch
+)
+
+src_prepare() {
+ append-cxxflags '-std=c++11'
+ mv configure.in configure.ac || die
+ gnome2_src_prepare
+ eautoreconf
+}