summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-08-24 12:10:34 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-08-24 17:30:23 +0200
commit8ea53254df1c7e8f2497c3765155fc77d56e1a65 (patch)
treeff0c628a6b656e19a976b9a791a2791f8535ebf4 /sci-electronics
parentnet-misc/passt: use https:// instead of git:// for cloning (diff)
downloadgentoo-8ea53254df1c7e8f2497c3765155fc77d56e1a65.tar.gz
gentoo-8ea53254df1c7e8f2497c3765155fc77d56e1a65.tar.bz2
gentoo-8ea53254df1c7e8f2497c3765155fc77d56e1a65.zip
sci-electronics/ghdl: drop old 4.0.0-r1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/ghdl/Manifest1
-rw-r--r--sci-electronics/ghdl/ghdl-4.0.0-r1.ebuild90
2 files changed, 0 insertions, 91 deletions
diff --git a/sci-electronics/ghdl/Manifest b/sci-electronics/ghdl/Manifest
index e69dd5a5d142..496b50235c75 100644
--- a/sci-electronics/ghdl/Manifest
+++ b/sci-electronics/ghdl/Manifest
@@ -1,2 +1 @@
-DIST ghdl-4.0.0.tar.gz 7683124 BLAKE2B 2b43f1a24c9fb30f754ae6326b21fd52991f3bd69fc1c2dfbd3064d950cef74f7e66f2a846778e6429fbfae07d349f913993d91c52ec53cdad894b06f810cb03 SHA512 95b08274f2ed54556fbe2e72ce52605d9ca8269b535306348d25a259615a0610b59a61fb4458e0c1e548570361af15d45d89941bf4ab4afd2fafb10b07e69cae
DIST ghdl-4.1.0.tar.gz 7704716 BLAKE2B d69791d947ed11b62fac8e076c3b9e1bad606a0de57e8d5bd67c9a8f7ea0cad73643085efbaaa06fabdd5900366334b63385589da72f4db488f5b27b142a76f8 SHA512 0a3a465f7f8ed7fba9b81b5dec2903bf82731c97a127666e7644286c9ea80078354be4e6bf8947a6ef631b646dc7e8e69dce2d9a467ac36ee03c67d9335a2703
diff --git a/sci-electronics/ghdl/ghdl-4.0.0-r1.ebuild b/sci-electronics/ghdl/ghdl-4.0.0-r1.ebuild
deleted file mode 100644
index 7fb1396f35c1..000000000000
--- a/sci-electronics/ghdl/ghdl-4.0.0-r1.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-ADA_COMPAT=( gnat_2021 gcc_13 )
-LLVM_MAX_SLOT=17 # Check "configure" script for supported LLVM versions.
-
-inherit ada edo llvm toolchain-funcs
-
-DESCRIPTION="Open-source analyzer, compiler, and simulator for VHDL 2008/93/87"
-HOMEPAGE="https://ghdl.github.io/ghdl/
- https://github.com/ghdl/ghdl/"
-
-if [[ "${PV}" == *9999* ]] ; then
- inherit git-r3
-
- EGIT_REPO_URI="https://github.com/ghdl/${PN}.git"
-else
- SRC_URI="https://github.com/ghdl/${PN}/archive/v${PV}.tar.gz
- -> ${P}.tar.gz"
-
- KEYWORDS="amd64 ~x86"
-fi
-
-LICENSE="GPL-2+"
-SLOT="0"
-IUSE="llvm"
-REQUIRED_USE="${ADA_REQUIRED_USE}"
-
-RDEPEND="
- ${ADA_DEPS}
- llvm? ( <sys-devel/llvm-$((${LLVM_MAX_SLOT} + 1)):= )
-"
-DEPEND="
- ${RDEPEND}
-"
-BDEPEND="
- dev-util/patchelf
-"
-
-PATCHES=( "${FILESDIR}/${PN}-4.0.0_pre20231218-no-pyunit.patch" )
-
-pkg_setup() {
- ada_pkg_setup
-
- use llvm && llvm_pkg_setup
-}
-
-src_prepare() {
- default
-
- sed -i "s|ar rc|$(tc-getAR) rc|g" Makefile.in || die
-}
-
-src_configure() {
- tc-export CC CXX
-
- local -a myconf=(
- # Build.
- --disable-werror
-
- # Install location.
- --libdir=$(get_libdir)
- --prefix=/usr
-
- # Features.
- --enable-libghdl
- --enable-synth
- )
-
- if use llvm ; then
- myconf+=( --with-llvm-config=llvm-config )
- fi
-
- # Not a autotools script!
- edo sh ./configure "${myconf[@]}"
-}
-
-src_compile() {
- default
-
- patchelf --set-soname libghw.so lib/libghw.so || die
-}
-
-src_install() {
- default
-
- find "${ED}" -type f -name '*.a' -delete || die
-}