summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-05-16 10:12:16 +0200
committerDavid Seifert <soap@gentoo.org>2022-05-16 10:12:16 +0200
commitdcccf8e81b2bad576cf65d95055a47a78ec79f85 (patch)
tree49a8333f5ea9cadba721045154f227f386825af6 /sci-electronics
parentsci-electronics/kicad: [QA] use tc-check-openmp correctly (diff)
downloadgentoo-dcccf8e81b2bad576cf65d95055a47a78ec79f85.tar.gz
gentoo-dcccf8e81b2bad576cf65d95055a47a78ec79f85.tar.bz2
gentoo-dcccf8e81b2bad576cf65d95055a47a78ec79f85.zip
sci-electronics/ngspice: [QA] use tc-check-openmp correctly
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/ngspice/ngspice-31-r1.ebuild9
-rw-r--r--sci-electronics/ngspice/ngspice-34.ebuild9
-rw-r--r--sci-electronics/ngspice/ngspice-35.ebuild9
-rw-r--r--sci-electronics/ngspice/ngspice-36.ebuild7
4 files changed, 27 insertions, 7 deletions
diff --git a/sci-electronics/ngspice/ngspice-31-r1.ebuild b/sci-electronics/ngspice/ngspice-31-r1.ebuild
index 7195c9e60379..603365b18c66 100644
--- a/sci-electronics/ngspice/ngspice-31-r1.ebuild
+++ b/sci-electronics/ngspice/ngspice-31-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -40,11 +40,16 @@ DOCS=(
Stuarts_Poly_Notes
)
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+
MULTIBUILD_VARIANTS=( "binaries" )
use shared && MULTIBUILD_VARIANTS+=( "shared" )
use tcl && MULTIBUILD_VARIANTS+=( "tcl" )
- use openmp && tc-check-openmp
}
src_prepare() {
diff --git a/sci-electronics/ngspice/ngspice-34.ebuild b/sci-electronics/ngspice/ngspice-34.ebuild
index 9f70865e81ca..e0f41dc5b269 100644
--- a/sci-electronics/ngspice/ngspice-34.ebuild
+++ b/sci-electronics/ngspice/ngspice-34.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -41,11 +41,16 @@ DOCS=(
Stuarts_Poly_Notes
)
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+
MULTIBUILD_VARIANTS=( "binaries" )
use shared && MULTIBUILD_VARIANTS+=( "shared" )
use tcl && MULTIBUILD_VARIANTS+=( "tcl" )
- use openmp && tc-check-openmp
}
src_prepare() {
diff --git a/sci-electronics/ngspice/ngspice-35.ebuild b/sci-electronics/ngspice/ngspice-35.ebuild
index 17b7d8e33554..305f2906fb38 100644
--- a/sci-electronics/ngspice/ngspice-35.ebuild
+++ b/sci-electronics/ngspice/ngspice-35.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -40,11 +40,16 @@ DOCS=(
Stuarts_Poly_Notes
)
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+
MULTIBUILD_VARIANTS=( "binaries" )
use shared && MULTIBUILD_VARIANTS+=( "shared" )
use tcl && MULTIBUILD_VARIANTS+=( "tcl" )
- use openmp && tc-check-openmp
}
src_prepare() {
diff --git a/sci-electronics/ngspice/ngspice-36.ebuild b/sci-electronics/ngspice/ngspice-36.ebuild
index ded8f7f1d8ce..8a616095f439 100644
--- a/sci-electronics/ngspice/ngspice-36.ebuild
+++ b/sci-electronics/ngspice/ngspice-36.ebuild
@@ -40,11 +40,16 @@ DOCS=(
Stuarts_Poly_Notes
)
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+
MULTIBUILD_VARIANTS=( "binaries" )
use shared && MULTIBUILD_VARIANTS+=( "shared" )
use tcl && MULTIBUILD_VARIANTS+=( "tcl" )
- use openmp && tc-check-openmp
}
src_prepare() {