summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2025-01-01 12:47:39 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2025-01-01 17:47:45 +0100
commit501914d6f1c26befc8b3ce4888a0f0d60c76013a (patch)
tree436b73e0b660682560e693a08d697bf9791cd1f5 /sci-geosciences
parentnet-misc/moonlight: drop 6.1.0 (diff)
downloadgentoo-501914d6f1c26befc8b3ce4888a0f0d60c76013a.tar.gz
gentoo-501914d6f1c26befc8b3ce4888a0f0d60c76013a.tar.bz2
gentoo-501914d6f1c26befc8b3ce4888a0f0d60c76013a.zip
sci-geosciences/gpxsee: Drop IUSE qt5 (make Qt6 non-optional), fix deps
- Fix entirely missing dev-qt/qtbase:6 USEdeps - Add missing slot op on dev-qt/qtbase:6 (GuiPrivate dependency in .pro file) - Add missing BDEPEND=dev-qt/qttools:6[linguist] USEdep - Run eqmake in src_configure(), not src_compile() dev-qt/qtserialport:6 DEPEND appears to be upstream compensating for a dependency not having defined its link interface properly. Closes: https://bugs.gentoo.org/925596 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/gpxsee/gpxsee-13.33-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sci-geosciences/gpxsee/gpxsee-13.33-r1.ebuild b/sci-geosciences/gpxsee/gpxsee-13.33-r1.ebuild
new file mode 100644
index 000000000000..3bdb41535e80
--- /dev/null
+++ b/sci-geosciences/gpxsee/gpxsee-13.33-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="GPXSee"
+PLOCALES="ca cs da de en eo es fi fr hu it ko nb pl pt_BR ru sv tr uk zh_CN"
+inherit plocale qmake-utils xdg
+
+DESCRIPTION="Viewer and analyzer that supports gpx, tcx, kml, fit, igc and nmea files"
+HOMEPAGE="https://www.gpxsee.org/ https://github.com/tumic0/GPXSee"
+SRC_URI="https://github.com/tumic0/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ dev-qt/qtbase:6=[concurrent,gui,network,opengl,sql,widgets]
+ dev-qt/qtpositioning:6
+ dev-qt/qtsvg:6
+"
+DEPEND="${RDEPEND}
+ dev-qt/qtserialport:6
+"
+BDEPEND="dev-qt/qttools:6[linguist]"
+
+PATCHES=( "${FILESDIR}"/${PN}-7.33.patch )
+
+src_prepare() {
+ default
+
+ plocale_find_changes lang "${PN}_" '.ts'
+
+ rm_ts() {
+ sed -e "s|lang/gpxsee_${1}.ts||" -i gpxsee.pro
+ }
+
+ plocale_for_each_disabled_locale rm_ts
+}
+
+src_configure() {
+ $(qt6_get_bindir)/lrelease gpxsee.pro || die "lrelease failed"
+ eqmake6 gpxsee.pro
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ dodoc README.md
+}