summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-05-17 19:20:38 +0200
committerAlfredo Tupone <tupone@gentoo.org>2023-05-17 19:21:38 +0200
commit495a12b89714af51f7e154d7e1cdb86d6836ee2d (patch)
treeaf6ccb12ffe1abd7116579db236c19114781a80f /sci-libs/evaluate
parentsys-kernel/gentoo-sources: stabilize 4.14.315 as per kernel policy (diff)
downloadgentoo-495a12b89714af51f7e154d7e1cdb86d6836ee2d.tar.gz
gentoo-495a12b89714af51f7e154d7e1cdb86d6836ee2d.tar.bz2
gentoo-495a12b89714af51f7e154d7e1cdb86d6836ee2d.zip
sci-libs/evaluate: add datasets deps
Closes: https://bugs.gentoo.org/906591 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs/evaluate')
-rw-r--r--sci-libs/evaluate/evaluate-0.4.0-r1.ebuild (renamed from sci-libs/evaluate/evaluate-0.4.0.ebuild)14
1 files changed, 10 insertions, 4 deletions
diff --git a/sci-libs/evaluate/evaluate-0.4.0.ebuild b/sci-libs/evaluate/evaluate-0.4.0-r1.ebuild
index 60382685f160..f9caea3a3a19 100644
--- a/sci-libs/evaluate/evaluate-0.4.0.ebuild
+++ b/sci-libs/evaluate/evaluate-0.4.0-r1.ebuild
@@ -5,6 +5,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_11 )
+DISTUTILS_SINGLE_IMPL=1
inherit distutils-r1
DESCRIPTION="makes evaluating, comparing models and reporting their performance easier"
@@ -20,12 +21,17 @@ SLOT="0"
KEYWORDS="~amd64"
RDEPEND="
- dev-python/pyarrow[${PYTHON_USEDEP},parquet]
- dev-python/unidecode[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pyarrow[${PYTHON_USEDEP},parquet]
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ ')
+ sci-libs/datasets[${PYTHON_SINGLE_USEDEP}]
"
BDEPEND="test? (
- sci-libs/jiwer[${PYTHON_USEDEP}]
- sci-libs/seqeval[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ sci-libs/jiwer[${PYTHON_USEDEP}]
+ sci-libs/seqeval[${PYTHON_USEDEP}]
+ ')
)"
PATCHES=( "${FILESDIR}"/${P}-tests.patch )