summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-17 07:35:13 +0000
committerSam James <sam@gentoo.org>2022-05-17 07:35:55 +0000
commit4b3fb0086b61528086d4b4bde2fca8261b813e35 (patch)
treeb37138bdf397f06d5d7202fc83462a496686d209 /sci-libs/gdal
parentsci-libs/gdal: fix pkg-config include dir for 3.5.0 (diff)
downloadgentoo-4b3fb0086b61528086d4b4bde2fca8261b813e35.tar.gz
gentoo-4b3fb0086b61528086d4b4bde2fca8261b813e35.tar.bz2
gentoo-4b3fb0086b61528086d4b4bde2fca8261b813e35.zip
sci-libs/gdal: force JPEG support on for 3.5.0
Upstream recommend it, the build is broken without it, and while we could fix the build issue, I don't see much point for an extremely common dependency (especially given we're the first ones to notice the build is broken w/o it). Closes: https://bugs.gentoo.org/844751 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/gdal')
-rw-r--r--sci-libs/gdal/gdal-3.5.0-r2.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sci-libs/gdal/gdal-3.5.0-r2.ebuild b/sci-libs/gdal/gdal-3.5.0-r2.ebuild
index 42e368935481..93225abeab64 100644
--- a/sci-libs/gdal/gdal-3.5.0-r2.ebuild
+++ b/sci-libs/gdal/gdal-3.5.0-r2.ebuild
@@ -15,7 +15,7 @@ SRC_URI+=" test? ( https://download.osgeo.org/${PN}/${PV}/${PN}autotest-${PV}.ta
LICENSE="BSD Info-ZIP MIT"
SLOT="0/31" # subslot is libgdal.so.<SONAME>
KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="armadillo +curl cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse4_1 cpu_flags_x86_ssse3 doc fits geos gif gml hdf5 heif java jpeg jpeg2k lzma mysql netcdf odbc ogdi opencl oracle pdf png postgres python spatialite sqlite test webp xls zstd"
+IUSE="armadillo +curl cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse4_1 cpu_flags_x86_ssse3 doc fits geos gif gml hdf5 heif java jpeg2k lzma mysql netcdf odbc ogdi opencl oracle pdf png postgres python spatialite sqlite test webp xls zstd"
# Tests fail to build in 3.5.0, let's not worry too much yet given
# we're only just porting to CMake. Revisit later.
RESTRICT="!test? ( test ) test"
@@ -42,6 +42,7 @@ DEPEND="dev-libs/expat
dev-libs/libxml2:2
dev-libs/openssl:=
media-libs/tiff
+ media-libs/libjpeg-turbo:=
>=sci-libs/libgeotiff-1.5.1-r1:=
>=sci-libs/proj-6.0.0:=
sys-libs/zlib[minizip(+)]
@@ -53,7 +54,6 @@ DEPEND="dev-libs/expat
gml? ( >=dev-libs/xerces-c-3.1 )
heif? ( media-libs/libheif:= )
hdf5? ( >=sci-libs/hdf5-1.6.4:=[szip] )
- jpeg? ( media-libs/libjpeg-turbo:= )
jpeg2k? ( media-libs/openjpeg:2= )
lzma? ( || (
app-arch/xz-utils
@@ -134,7 +134,7 @@ src_configure() {
-DGDAL_USE_HDFS=OFF
-DGDAL_USE_ICONV=ON # TODO dep
-DGDAL_USE_IDB=OFF
- -DGDAL_USE_JPEG=$(usex jpeg)
+ -DGDAL_USE_JPEG=ON
# https://gdal.org/build_hints.html#jpeg12
# Independent of whether using system libjpeg