summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-13 20:08:50 -0400
committerSam James <sam@gentoo.org>2024-03-14 00:34:35 +0000
commit7ce90bf1fd107e51cc1ab921fe32fb7fdefabe0d (patch)
tree0257fd8f4971832e1d6b4b7226dbf349862f02d3 /sci-libs/geos
parentmedia-gfx/graphite2: filter LTO (diff)
downloadgentoo-7ce90bf1fd107e51cc1ab921fe32fb7fdefabe0d.tar.gz
gentoo-7ce90bf1fd107e51cc1ab921fe32fb7fdefabe0d.tar.bz2
gentoo-7ce90bf1fd107e51cc1ab921fe32fb7fdefabe0d.zip
sci-libs/geos: mark as LTO-unsafe
Closes: https://bugs.gentoo.org/862702 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/geos')
-rw-r--r--sci-libs/geos/geos-3.11.2.ebuild7
-rw-r--r--sci-libs/geos/geos-3.12.0.ebuild7
-rw-r--r--sci-libs/geos/geos-3.12.1.ebuild7
3 files changed, 18 insertions, 3 deletions
diff --git a/sci-libs/geos/geos-3.11.2.ebuild b/sci-libs/geos/geos-3.11.2.ebuild
index 6ff66b24d49b..ea63aa08b670 100644
--- a/sci-libs/geos/geos-3.11.2.ebuild
+++ b/sci-libs/geos/geos-3.11.2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="Geometry engine library for Geographic Information Systems"
HOMEPAGE="https://libgeos.org/"
@@ -22,6 +22,11 @@ PATCHES=(
)
src_configure() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/862702
+ # https://github.com/libgeos/geos/issues/1054
+ filter-lto
+
local mycmakeargs=(
-DBUILD_DOCUMENTATION=$(usex doc)
-DBUILD_TESTING=$(usex test)
diff --git a/sci-libs/geos/geos-3.12.0.ebuild b/sci-libs/geos/geos-3.12.0.ebuild
index 3cd12a9122d1..71105c249023 100644
--- a/sci-libs/geos/geos-3.12.0.ebuild
+++ b/sci-libs/geos/geos-3.12.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="Geometry engine library for Geographic Information Systems"
HOMEPAGE="https://libgeos.org/"
@@ -18,6 +18,11 @@ RESTRICT="!test? ( test )"
BDEPEND="doc? ( app-text/doxygen )"
src_configure() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/862702
+ # https://github.com/libgeos/geos/issues/1054
+ filter-lto
+
local mycmakeargs=(
-DBUILD_DOCUMENTATION=$(usex doc)
-DBUILD_TESTING=$(usex test)
diff --git a/sci-libs/geos/geos-3.12.1.ebuild b/sci-libs/geos/geos-3.12.1.ebuild
index 3cd12a9122d1..71105c249023 100644
--- a/sci-libs/geos/geos-3.12.1.ebuild
+++ b/sci-libs/geos/geos-3.12.1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="Geometry engine library for Geographic Information Systems"
HOMEPAGE="https://libgeos.org/"
@@ -18,6 +18,11 @@ RESTRICT="!test? ( test )"
BDEPEND="doc? ( app-text/doxygen )"
src_configure() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/862702
+ # https://github.com/libgeos/geos/issues/1054
+ filter-lto
+
local mycmakeargs=(
-DBUILD_DOCUMENTATION=$(usex doc)
-DBUILD_TESTING=$(usex test)