summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/jmol-acme
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/jmol-acme')
-rw-r--r--sci-libs/jmol-acme/Manifest1
-rw-r--r--sci-libs/jmol-acme/files/src.list4
-rw-r--r--sci-libs/jmol-acme/jmol-acme-1.0.ebuild41
-rw-r--r--sci-libs/jmol-acme/metadata.xml11
4 files changed, 57 insertions, 0 deletions
diff --git a/sci-libs/jmol-acme/Manifest b/sci-libs/jmol-acme/Manifest
new file mode 100644
index 000000000000..8319666ecae0
--- /dev/null
+++ b/sci-libs/jmol-acme/Manifest
@@ -0,0 +1 @@
+DIST Acme.tar.gz 478667 RMD160 a58ee00fe9abbb6149aa4b0baebcf9df8e9ec144 SHA1 421c7f69045242523948abe1e7e01092fd544b6e SHA256 6becb7e097bc9a3c7b39a42aaf8dd9ce8d35508b5221c3076e0c1e060ecc688c
diff --git a/sci-libs/jmol-acme/files/src.list b/sci-libs/jmol-acme/files/src.list
new file mode 100644
index 000000000000..14d1fc028561
--- /dev/null
+++ b/sci-libs/jmol-acme/files/src.list
@@ -0,0 +1,4 @@
+./IntHashtable.java
+./JPM/Encoders/GifEncoder.java
+./JPM/Encoders/ImageEncoder.java
+./JPM/Encoders/PpmEncoder.java
diff --git a/sci-libs/jmol-acme/jmol-acme-1.0.ebuild b/sci-libs/jmol-acme/jmol-acme-1.0.ebuild
new file mode 100644
index 000000000000..279d21770797
--- /dev/null
+++ b/sci-libs/jmol-acme/jmol-acme-1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="Acme"
+
+# It proved difficult to recompile the whole Acme package, so we'll only take what we need.
+
+DESCRIPTION="Portions of the Acme collection required for jMol"
+HOMEPAGE="http://www.acme.com/"
+SRC_URI="http://www.acme.com/resources/classes/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4"
+RDEPEND=">=virtual/jre-1.4"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ mkdir -p classes
+ find . -name \*.class -delete
+ java-pkg_filter-compiler jikes
+}
+
+src_compile() {
+ cp "${FILESDIR}/src.list" "${T}" || die
+ ejavac -sourcepath "" -d "${S}/classes" "@${T}/src.list"
+ jar cf "${PN}.jar" -C classes . || die "failed to create jar"
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+}
diff --git a/sci-libs/jmol-acme/metadata.xml b/sci-libs/jmol-acme/metadata.xml
new file mode 100644
index 000000000000..67f88fe8ce1f
--- /dev/null
+++ b/sci-libs/jmol-acme/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>je_fro@gentoo.org</email>
+ <name>Jeff Gardner</name>
+ </maintainer>
+ <longdescription lang="en">
+</longdescription>
+</pkgmetadata>