summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-12-20 13:18:48 +0000
committerMarek Szuba <marecki@gentoo.org>2020-12-20 13:28:57 +0000
commitb136f3d38de4caab673aff7ec9e33b5c4a603d7a (patch)
treee04af4c6aa4c5f48c0029ca83622590bff024bd6 /sci-libs/p4est/p4est-9999.ebuild
parentsci-libs/libsc: migrate to lua-single.eclass (diff)
downloadgentoo-b136f3d38de4caab673aff7ec9e33b5c4a603d7a.tar.gz
gentoo-b136f3d38de4caab673aff7ec9e33b5c4a603d7a.tar.bz2
gentoo-b136f3d38de4caab673aff7ec9e33b5c4a603d7a.zip
sci-libs/p4est: migrate to lua-single.eclass
Both the latest release and the live ebuild. Doesn't do any Lua detection by itself, relies on libsc configuration instead. Therefore, the same compatibility as respective libsc versions. Status: - 2.2-r100 builds, tests and installs fine - 9999 untested due to build failures in sci-libs/libsc-9999 Closes: https://bugs.gentoo.org/752846 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'sci-libs/p4est/p4est-9999.ebuild')
-rw-r--r--sci-libs/p4est/p4est-9999.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/sci-libs/p4est/p4est-9999.ebuild b/sci-libs/p4est/p4est-9999.ebuild
index 7f8e399758eb..cf8dea879cea 100644
--- a/sci-libs/p4est/p4est-9999.ebuild
+++ b/sci-libs/p4est/p4est-9999.ebuild
@@ -1,12 +1,14 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..3} )
# The build system currently fails with everything newer than 1.11.
WANT_AUTOMAKE=1.11
-inherit autotools toolchain-funcs eutils
+inherit autotools lua-single toolchain-funcs eutils
DESCRIPTION="Scalable Algorithms for Parallel Adaptive Mesh Refinement on Forests of Octrees"
HOMEPAGE="http://www.p4est.org/"
@@ -29,11 +31,11 @@ SLOT="0"
# TODO petsc
IUSE="debug doc examples mpi openmp romio static-libs threads +vtk-binary"
-REQUIRED_USE="romio? ( mpi )"
+REQUIRED_USE="${LUA_REQUIRED_USE}
+ romio? ( mpi )"
-RDEPEND="
- ~sci-libs/libsc-${PV}[mpi=,openmp=,romio=,static-libs=,threads=]
- dev-lang/lua:0=
+RDEPEND="${LUA_DEPS}
+ ~sci-libs/libsc-${PV}[${LUA_SINGLE_USEDEP},mpi=,openmp=,romio=,static-libs=,threads=]
sys-apps/util-linux
virtual/blas
virtual/lapack