summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2023-07-09 11:48:30 +0700
committerAndrey Grozin <grozin@gentoo.org>2023-07-09 11:48:54 +0700
commit0eb5f79cd03d0aa4da0f7edd2ae62af3887429c3 (patch)
treed05616e2387d9f91c9b5f161c965b6a4de1544b8 /sci-mathematics/fricas
parentprofiles/features/big-endian: mask media-libs/libjxl (diff)
downloadgentoo-0eb5f79cd03d0aa4da0f7edd2ae62af3887429c3.tar.gz
gentoo-0eb5f79cd03d0aa4da0f7edd2ae62af3887429c3.tar.bz2
gentoo-0eb5f79cd03d0aa4da0f7edd2ae62af3887429c3.zip
sci-mathematics/fricas: bump to 1.3.9
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-mathematics/fricas')
-rw-r--r--sci-mathematics/fricas/Manifest1
-rw-r--r--sci-mathematics/fricas/fricas-1.3.9.ebuild110
-rw-r--r--sci-mathematics/fricas/metadata.xml1
3 files changed, 112 insertions, 0 deletions
diff --git a/sci-mathematics/fricas/Manifest b/sci-mathematics/fricas/Manifest
index 276c12bbc607..f880d5c7a0bf 100644
--- a/sci-mathematics/fricas/Manifest
+++ b/sci-mathematics/fricas/Manifest
@@ -1 +1,2 @@
DIST fricas-1.3.8-full.tar.bz2 10878913 BLAKE2B 214eecd430a2b758a10d985f512f3c79f6b12de35bc29e8f0a3fd296fe871b2e9a6b362060cbeec317dc355bd3c661fcab44087feeaa092fe6afcdebd0fb94a8 SHA512 330554f9dc36b47451195e3dee88fe26a80ab2bf9b6750d651cd53c5ba16b9c9736176936c7c69e699685be25aa62b6a099ed7340913e946a4f5e53579835dbb
+DIST fricas-1.3.9.full.tar.bz2 10949173 BLAKE2B c535d2a384fa55db53b6901d3ba5d1cc8eca35ccf67a2664f934da427a808b5adc7a5522b935f5dcff89795c0ca5816818d9cf37399b6f9bdc63cfe4d622a7c3 SHA512 9cfcb8bad52550a46216509154d5c06dac23625bc14d504a1febbea7ff771fd3172f91c2824df51375b8d85adc19959a5cbbfa2b77a0095ca37e8a4d4b8cc405
diff --git a/sci-mathematics/fricas/fricas-1.3.9.ebuild b/sci-mathematics/fricas/fricas-1.3.9.ebuild
new file mode 100644
index 000000000000..e3004457c1e1
--- /dev/null
+++ b/sci-mathematics/fricas/fricas-1.3.9.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit elisp-common
+
+DESCRIPTION="FriCAS is a fork of Axiom computer algebra system"
+HOMEPAGE="http://fricas.sourceforge.net/
+ https://github.com/fricas/fricas
+ https://fricas.github.io/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}.full.tar.bz2"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Supported lisps, number 0 is the default
+LISPS=( sbcl cmucl gcl ecls clisp clozurecl )
+# Version restrictions, . means no restrictions
+REST=( . . . . . . )
+# command name: . means just ${LISP}
+COMS=( . lisp . ecl . ccl )
+
+IUSE="${LISPS[*]} X emacs gmp"
+RDEPEND="X? ( x11-libs/libXpm x11-libs/libICE )
+ emacs? ( >=app-editors/emacs-23.1:* )
+ gmp? ( dev-libs/gmp:= )"
+
+# Generating lisp deps
+n=${#LISPS[*]}
+for ((n--; n > 0; n--)); do
+ LISP=${LISPS[$n]}
+ if [ "${REST[$n]}" = "." ]; then
+ DEP="dev-lisp/${LISP}"
+ else
+ DEP="${REST[$n]}"
+ fi
+ RDEPEND="${RDEPEND} ${LISP}? ( ${DEP}:= ) !${LISP}? ("
+done
+if [ "${REST[0]}" = "." ]; then
+ DEP="dev-lisp/${LISPS[0]}"
+else
+ DEP="${REST[0]}"
+fi
+RDEPEND="${RDEPEND} ${DEP}:="
+n=${#LISPS[*]}
+for ((n--; n > 0; n--)); do
+ RDEPEND="${RDEPEND} )"
+done
+
+DEPEND="${RDEPEND}"
+
+# necessary for clisp and gcl
+RESTRICT="strip"
+
+src_configure() {
+ local LISP n GMP
+ LISP=sbcl
+ n=${#LISPS[*]}
+ for ((n--; n > 0; n--)); do
+ if use ${LISPS[$n]}; then
+ LISP=${COMS[$n]}
+ if [ "${LISP}" = "." ]; then
+ LISP=${LISPS[$n]}
+ fi
+ fi
+ done
+ einfo "Using lisp: ${LISP}"
+
+ # bug #650788
+ if [[ ${LISP} = sbcl || ${LISP} = ccl ]]
+ then GMP=$(use_with gmp)
+ else GMP=''
+ fi
+
+ # aldor is not yet in portage
+ econf --disable-aldor --with-lisp=${LISP} $(use_with X x) ${GMP}
+}
+
+src_compile() {
+ # bug #300132
+ emake -j1
+}
+
+src_test() {
+ emake -j1 all-input
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ dodoc README.rst FAQ
+
+ if use emacs; then
+ sed -e "s|(setq load-path (cons (quote \"/usr/$(get_libdir)/fricas/emacs\") load-path)) ||" \
+ -i "${D}"/usr/bin/efricas \
+ || die "sed efricas failed"
+ elisp-install ${PN} "${D}"/usr/$(get_libdir)/${PN}/emacs/*.el
+ elisp-make-site-file 64${PN}-gentoo.el
+ else
+ rm "${D}"/usr/bin/efricas || die "rm efricas failed"
+ fi
+ rm -r "${D}"/usr/$(get_libdir)/${PN}/emacs || die "rm -r emacs failed"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/sci-mathematics/fricas/metadata.xml b/sci-mathematics/fricas/metadata.xml
index c17dd82db612..5f547acf8a41 100644
--- a/sci-mathematics/fricas/metadata.xml
+++ b/sci-mathematics/fricas/metadata.xml
@@ -25,5 +25,6 @@
</use>
<upstream>
<remote-id type="sourceforge">fricas</remote-id>
+ <remote-id type="github">fricas/fricas</remote-id>
</upstream>
</pkgmetadata>