summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2016-02-20 10:25:42 +0100
committerThomas Kahle <tomka@gentoo.org>2016-02-20 10:25:57 +0100
commitd6b4ca304f506e249b4bad781446be35dac3eccf (patch)
treef72419d19dd29ba1aeb0bd2d0756ea9eaef0bbfa /sci-mathematics/normaliz
parentsys-kernel/raspberrypi-image: Fix Whitespace and Header (diff)
downloadgentoo-d6b4ca304f506e249b4bad781446be35dac3eccf.tar.gz
gentoo-d6b4ca304f506e249b4bad781446be35dac3eccf.tar.bz2
gentoo-d6b4ca304f506e249b4bad781446be35dac3eccf.zip
sci-mathematics/normaliz: Bump to 3.1.0
Package-Manager: portage-2.2.26
Diffstat (limited to 'sci-mathematics/normaliz')
-rw-r--r--sci-mathematics/normaliz/Manifest1
-rw-r--r--sci-mathematics/normaliz/normaliz-3.1.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/sci-mathematics/normaliz/Manifest b/sci-mathematics/normaliz/Manifest
index bf7a9f9e6713..441eacac7c96 100644
--- a/sci-mathematics/normaliz/Manifest
+++ b/sci-mathematics/normaliz/Manifest
@@ -1,2 +1,3 @@
DIST Normaliz2.12.2.zip 6432949 SHA256 230772425b3c9964b9e144c0919c75fac0ec95260a1943c10a8a94eea9d7273e SHA512 fd42071cb87b8efbaf9af0885c173a0583e0b38dedb8821a83225eeebb44060a7b5748c44adfc4faeac20c3a1706071bcb9883cb4447e4a1ff3aeb770bd22038 WHIRLPOOL cb2974e02eac6e6d51c234214a719a24ad2e12d1400f0a6f8aee3e7a4ba3aa2ba053beec65c9032f42726e4dd4f1866820bb5b7b96f7c3d34cd132fcdbdb91af
DIST Normaliz3.0.0.zip 8607387 SHA256 4dbc315de34a1f115a911194b22628948a32a993c486bda03623e6786172857b SHA512 b4ce7b5ab849982ee986e3b1cbef1ed620ddf57c8d89ef3d5973509ead52d49c2a59a2924357fb70838963ec1490f68cfe0c5c294b05c571402f8445234bdbf5 WHIRLPOOL f90b81eb7ea426a393cd515932765ad9e48b888e47c07a709ab085f15960c4cda4c70f90ba61bf590bbe9a2ee2ca125a46bd9a24bb0940c1e2b09203b0f16452
+DIST Normaliz3.1.0.zip 5734218 SHA256 dfb6b801c4a4bb9aeec6601c58eca2c92bfc420d126c5e0dce0e1f2cdb7d8200 SHA512 835f39cfcd7b6b39139a7c731320e297df2e7a41d0e68e0bfb4d72b9d6905a8b83b1ef61408458c071315933968290d5166470445cd19af4ef1b5ac6ba04496a WHIRLPOOL 25fedc897515fc4b8ce2ec82f70a2c2474b63d928c22126f140f69836af3f7af0cf9de9e1849ae6a886155e5ceabcedc8a42b234ad939648f5278302cb7a1950
diff --git a/sci-mathematics/normaliz/normaliz-3.1.0.ebuild b/sci-mathematics/normaliz/normaliz-3.1.0.ebuild
new file mode 100644
index 000000000000..161c8949a772
--- /dev/null
+++ b/sci-mathematics/normaliz/normaliz-3.1.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs versionator
+
+MYPV=$(get_version_component_range 1-2)
+MYP="Normaliz${MYPV}"
+
+DESCRIPTION="Tool for computations in affine monoids and more"
+HOMEPAGE="www.mathematik.uni-osnabrueck.de/normaliz/"
+SRC_URI="https://www.normaliz.uni-osnabrueck.de/wp-content/uploads/2016/02/Normaliz${PV}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc extras openmp"
+
+RDEPEND="dev-libs/gmp[cxx]"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-libs/boost"
+# Only a boost header is needed -> not RDEPEND
+
+S=${WORKDIR}/${MYP}
+
+src_prepare () {
+ epatch "${FILESDIR}/${PN}-3.0.0-respect-flags.patch"
+
+ # Respect users AR tool (Bug 474532)
+ sed -e "s:ar -cr:$(tc-getAR) -cr:" -i source/libnormaliz/Makefile || die
+
+ if use openmp && tc-has-openmp; then
+ export OPENMP=yes
+ else
+ export OPENMP=no
+ fi
+}
+
+src_compile(){
+ emake CXX="$(tc-getCXX)" OPENMP="${OPENMP}" -C source
+}
+
+src_install() {
+ dobin source/normaliz
+ if use doc ; then
+ dodoc doc/"Normaliz.pdf"
+ dodoc doc/"NmzIntegrate.pdf"
+ fi
+ if use extras; then
+ elog "You have selected to install extras which consist of Macaulay2"
+ elog "and Singular packages. These have been installed into "
+ elog "/usr/share/${PN}, and cannot be used without additional setup. Please refer"
+ elog "to the homepages of the respective projects for additional information."
+ elog "Note however, Gentoo's versions of Singular and Macaulay2 bring their own"
+ elog "copies of these interface packages. Usually you don't need normaliz's versions."
+ insinto "/usr/share/${PN}"
+ doins Singular/normaliz.lib
+ doins Macaulay2/Normaliz.m2
+ fi
+}