summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-01-10 05:20:24 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-01-10 05:22:47 +0100
commit2257ce4ba9a5d9beb061ccff9ddb604ce77eb8bd (patch)
treef4e13e32c04cf30b9fd00df5f52c9c0c3d1797a7 /sci-mathematics
parentsci-mathematics/z3: update metadata xml (diff)
downloadgentoo-2257ce4ba9a5d9beb061ccff9ddb604ce77eb8bd.tar.gz
gentoo-2257ce4ba9a5d9beb061ccff9ddb604ce77eb8bd.tar.bz2
gentoo-2257ce4ba9a5d9beb061ccff9ddb604ce77eb8bd.zip
sci-mathematics/kissat: new package; add 3.0.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/kissat/Manifest1
-rw-r--r--sci-mathematics/kissat/kissat-3.0.0.ebuild37
-rw-r--r--sci-mathematics/kissat/metadata.xml19
3 files changed, 57 insertions, 0 deletions
diff --git a/sci-mathematics/kissat/Manifest b/sci-mathematics/kissat/Manifest
new file mode 100644
index 000000000000..33be7b881bb0
--- /dev/null
+++ b/sci-mathematics/kissat/Manifest
@@ -0,0 +1 @@
+DIST kissat-3.0.0.tar.gz 466704 BLAKE2B 453f894884e80cfd0ee7022adbde0439d64e31a402c4bfa92f022ad41699cc5c11682d5b9069cf33f8a779afa255f103987519bc9412b49f54480bd688fbc4eb SHA512 2a5b7b9c9bb74ca8395399425519c138e135eb9adfb6e802ce8d7544c9d53e0b7687f86e6a032fcdff1c6fc01770dd7e7449e488e0ddf3e4ee1199e1448a0862
diff --git a/sci-mathematics/kissat/kissat-3.0.0.ebuild b/sci-mathematics/kissat/kissat-3.0.0.ebuild
new file mode 100644
index 000000000000..3c36cf0cd9ef
--- /dev/null
+++ b/sci-mathematics/kissat/kissat-3.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Keep-it-simple and clean bare metal SAT solver written in C"
+HOMEPAGE="http://fmv.jku.at/kissat/
+ https://github.com/arminbiere/kissat/"
+SRC_URI="https://github.com/arminbiere/${PN}/archive/rel-${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-rel-${PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_configure() {
+ local myopts=(
+ CC="$(tc-getCC) ${CFLAGS} ${LDFLAGS}"
+ --kitten
+ --statistics
+ )
+ sh ./configure "${myopts[@]}" || die
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ dolib.a build/libkissat.a
+ exeinto /usr/bin/
+ doexe build/{kissat,kitten}
+ dodoc CONTRIBUTING NEWS.md README.md
+}
diff --git a/sci-mathematics/kissat/metadata.xml b/sci-mathematics/kissat/metadata.xml
new file mode 100644
index 000000000000..89067a2c8952
--- /dev/null
+++ b/sci-mathematics/kissat/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription>
+ Kissat is a "keep it simple and clean bare metal SAT solver" written in C.
+ It is a port of CaDiCaL back to C with improved data structures, better
+ scheduling of inprocessing and optimized algorithms and implementation.
+ Coincidentally "kissat" also means "cats" in Finnish.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/arminbiere/kissat//issues/</bugs-to>
+ <remote-id type="github">arminbiere/kissat</remote-id>
+ </upstream>
+</pkgmetadata>