summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-10-08 00:13:22 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-10-08 00:39:05 +0200
commit3f9ce223eb964305658c79338d9e8ec59cbf6a91 (patch)
tree848f3e7c570e7f4b64153040961fda513420030e /sci-mathematics
parentdev-db/litedb: use RollForward to update to .NET 7.0 (diff)
downloadgentoo-3f9ce223eb964305658c79338d9e8ec59cbf6a91.tar.gz
gentoo-3f9ce223eb964305658c79338d9e8ec59cbf6a91.tar.bz2
gentoo-3f9ce223eb964305658c79338d9e8ec59cbf6a91.zip
sci-mathematics/cadical: bump to 1.8.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/cadical/Manifest1
-rw-r--r--sci-mathematics/cadical/cadical-1.8.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sci-mathematics/cadical/Manifest b/sci-mathematics/cadical/Manifest
index 5eb8e04503e5..ca4b2f0275f0 100644
--- a/sci-mathematics/cadical/Manifest
+++ b/sci-mathematics/cadical/Manifest
@@ -1 +1,2 @@
DIST cadical-1.5.3.tar.gz 596378 BLAKE2B 1ac27412745b0f24668ccf2ea1ff89e02c1e68137110bf9522a63ad82b14621d898d0bf873a651a24ccef9f502982f5e2d5b9c558ed0b1c5b7432c1a1459cb58 SHA512 bec811ab6a4c392506bdc391227d108476b5b5fae280b2d7d484429fe6d84e86206a054a1044cf68046ce183ecd7af3ec58f8be3ac27224fe37930cf43f08f3b
+DIST cadical-1.8.0.tar.gz 649017 BLAKE2B 73db2dd0278869bc1b4fe5d1eb80e767a07c640bcd2b1901d86901a09ac6b8bdbe375017593c12ac80d7a860a0aead191777ce733452741395bf14b958bd1b03 SHA512 78dfd4a4a93090e3e00fa73c0dfde6edc781e8a69f257506f273cac46b942979335c2ae0ac1054bde68259b030ba235615275307ad077762c8770884914cfed7
diff --git a/sci-mathematics/cadical/cadical-1.8.0.ebuild b/sci-mathematics/cadical/cadical-1.8.0.ebuild
new file mode 100644
index 000000000000..a71f7eebe39d
--- /dev/null
+++ b/sci-mathematics/cadical/cadical-1.8.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simplified Satisfiability Solver"
+HOMEPAGE="http://fmv.jku.at/cadical/"
+SRC_URI="https://github.com/arminbiere/${PN}/archive/rel-${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-rel-${PV}"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-configure.patch
+ "${FILESDIR}"/${PN}-makefile.in-ar.patch
+)
+
+DOCS=( BUILD.md CONTRIBUTING NEWS.md README.md VERSION )
+
+src_configure() {
+ tc-export AR
+ CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS} ${LDFLAGS}" ./configure || die
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe build/{cadical,mobical}
+
+ dolib.a build/libcadical.a
+ doheader src/cadical.hpp
+ doheader src/ccadical.h
+
+ einstalldocs
+}