summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2022-12-21 06:54:14 -0500
committerMichael Orlitzky <mjo@gentoo.org>2022-12-21 07:31:29 -0500
commit51d4152d42632bebc19aa1e3200923ced385c535 (patch)
tree8254047a2f153c33321a0b0bea5ffd249898e101 /sci-mathematics
parentdev-libs/libratbag: add 0.17 (diff)
downloadgentoo-51d4152d42632bebc19aa1e3200923ced385c535.tar.gz
gentoo-51d4152d42632bebc19aa1e3200923ced385c535.tar.bz2
gentoo-51d4152d42632bebc19aa1e3200923ced385c535.zip
sci-mathematics/eclib: add 20221012
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/eclib/Manifest1
-rw-r--r--sci-mathematics/eclib/eclib-20221012.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sci-mathematics/eclib/Manifest b/sci-mathematics/eclib/Manifest
index 9c87eddbdb05..361eb7020548 100644
--- a/sci-mathematics/eclib/Manifest
+++ b/sci-mathematics/eclib/Manifest
@@ -1 +1,2 @@
DIST eclib-20220621.tar.bz2 921610 BLAKE2B f53f0648f09e427ae9b208a17c93f9808c2ab859cc41db6b5acb3b1382e9aaee93b17cd9d94c14e7f4941f140749d91b2ad94ad684f8a2c0f6033ac042cc89e7 SHA512 45cc47256f6ccbf2a00711d14533cffe8a3fc0dfea3d94d9823ac43af8a56cfe95485f0559c9141203910e85b1d3fa3284ee12ca5e53d083b74cbb2907afca42
+DIST eclib-20221012.tar.bz2 922112 BLAKE2B 2a6e5dccdef7c3c3b8bb1a121706bbfbcaafa9fb50882e4e88f8fa826c3b1bcbec11dc55462cbd51da3ab263991ae357b151ff3bdbf453abfc30e82d2abdeac8 SHA512 9d04aefe9e35fbc1b18dd92b5ba872cf71f5ce1c94c9a0f1ff326c763bf144112d7d950ac80e2bd8d3780a303edeeac903754b4eb5fb241e87be7ef3f2738c19
diff --git a/sci-mathematics/eclib/eclib-20221012.ebuild b/sci-mathematics/eclib/eclib-20221012.ebuild
new file mode 100644
index 000000000000..0266953df5d9
--- /dev/null
+++ b/sci-mathematics/eclib/eclib-20221012.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Programs for elliptic curves defined over the rational numbers"
+HOMEPAGE="https://github.com/JohnCremona/eclib"
+SRC_URI="https://github.com/JohnCremona/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+
+# Major version of /usr/lib64/libec.so
+# It *should* be at 11 in v20221012, as this commit shows,
+#
+# https://github.com/JohnCremona/eclib/commit/b63b8bb
+#
+# but it's actually still at 10, probably due to a forgotten autoreconf
+# or something.
+SLOT="0/11"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="boost flint minimal test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sci-mathematics/pari:=
+ dev-libs/ntl:=
+ boost? ( dev-libs/boost:= )
+ flint? ( sci-mathematics/flint:= )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ $(usex minimal --disable-allprogs "" "" "") \
+ $(use_with boost) \
+ $(use_with flint)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}