summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-10-08 16:46:45 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-10-08 18:42:22 +0200
commitb028a2c63ff7fe94201305761d6d9daf3745af5f (patch)
treee8f79c132fb37da425d671dfa60607cfdd033c60 /sci-mathematics
parentdev-python/python-stdnum: Version bumps (diff)
downloadgentoo-b028a2c63ff7fe94201305761d6d9daf3745af5f.tar.gz
gentoo-b028a2c63ff7fe94201305761d6d9daf3745af5f.tar.bz2
gentoo-b028a2c63ff7fe94201305761d6d9daf3745af5f.zip
sci-mathematics/octave: Fix >=qscintilla-2.10 detection
Gentoo-bug: 617024 Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/octave/files/octave-4.2.0-fix-qscintilla-detection.patch2
-rw-r--r--sci-mathematics/octave/octave-4.2.1.ebuild12
2 files changed, 12 insertions, 2 deletions
diff --git a/sci-mathematics/octave/files/octave-4.2.0-fix-qscintilla-detection.patch b/sci-mathematics/octave/files/octave-4.2.0-fix-qscintilla-detection.patch
index 9d18b6a6d7ce..ea714ecbfbbf 100644
--- a/sci-mathematics/octave/files/octave-4.2.0-fix-qscintilla-detection.patch
+++ b/sci-mathematics/octave/files/octave-4.2.0-fix-qscintilla-detection.patch
@@ -8,7 +8,7 @@ as its Qt4 variant.
5)
QT_MODULES="Qt5Core Qt5Gui Qt5Network Qt5OpenGL Qt5PrintSupport"
- octave_qscintilla_libnames="qscintilla2-qt5 qt5scintilla2"
-+ octave_qscintilla_libnames=qscintilla2
++ octave_qscintilla_libnames="qscintilla2_qt5 qscintilla2"
;;
*)
AC_MSG_ERROR([Unrecognized Qt version $qt_version])
diff --git a/sci-mathematics/octave/octave-4.2.1.ebuild b/sci-mathematics/octave/octave-4.2.1.ebuild
index 00a2d44ce48e..e7ecf516cc42 100644
--- a/sci-mathematics/octave/octave-4.2.1.ebuild
+++ b/sci-mathematics/octave/octave-4.2.1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit autotools flag-o-matic fortran-2 java-pkg-opt-2 pax-utils toolchain-funcs
+inherit autotools flag-o-matic fortran-2 java-pkg-opt-2 pax-utils toolchain-funcs xdg-utils
DESCRIPTION="High-level interactive language for numerical computations"
LICENSE="GPL-3"
@@ -175,3 +175,13 @@ src_install() {
echo "LDPATH=${EPREFIX}/usr/$(get_libdir)/${PN}/${PV}" > 99octave || die
doenvd 99octave
}
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}