summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-09-20 00:00:38 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-09-20 00:01:39 +0200
commitd88a1ae9ef4b750d5fc037faf997dd5c55a75500 (patch)
treebff1d037fe89af1955e5367516656c8bb6c49733 /sci-mathematics
parentsci-mathematics/lean: drop ~x86 KEYWORD (diff)
downloadgentoo-d88a1ae9ef4b750d5fc037faf997dd5c55a75500.tar.gz
gentoo-d88a1ae9ef4b750d5fc037faf997dd5c55a75500.tar.bz2
gentoo-d88a1ae9ef4b750d5fc037faf997dd5c55a75500.zip
sci-mathematics/lean: bump to 4.11.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/lean/Manifest1
-rw-r--r--sci-mathematics/lean/lean-4.11.0.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/sci-mathematics/lean/Manifest b/sci-mathematics/lean/Manifest
index 9354c00ca642..0a4a177afa1f 100644
--- a/sci-mathematics/lean/Manifest
+++ b/sci-mathematics/lean/Manifest
@@ -1,2 +1,3 @@
DIST lean-3.51.1.tar.gz 1918894 BLAKE2B 9a240fe73193794a57001582c0623052cfc1c08ef3b155cac2d9dfc029202cb79b85e844fdf068e454498a35522ec3e18330da8c644bba3c6f708cbde04816f7 SHA512 dccdf6c3fbcd98115e62b9944645af6a2ce21412d63baa9565871807862e8d83cc6f29d1fb687f19b802240a5f9c019443caa00412ecfabe621744dff900e3ee
+DIST lean-4.11.0.tar.gz 25790812 BLAKE2B d9a4eb15199f81c6757acf35fb17c795bb9d69158c7e7deb11d98a45bebf569dcda5f7733b2effd2be0eea879a6c7c24b270d97159e5898215e82e853320918c SHA512 2314659910b4d872c4ae0dda648a9cab9e1cc44cd4c55486a494b65b20fdae236ab9db99a42d7fb1a80030e300e95606065ee7dd27578b12a4c47fc8c102e2bb
DIST lean-4.2.0.tar.gz 16382466 BLAKE2B 3a8770d92ae89041f3e12089c3bb9171a993e8a1c702162925b569e13ed8d8819b3e9aa3c00e314a80a118ff8e4b18fb6df8b8a0e85a21fcb1daa5c0bfc29d4f SHA512 b0bd91f39319c1c6fd6851732d9dcb8758734500abc8faf0648c03582a81d51f2d942fa5deecedf81116b894d0b65e93eccab557bf155e69d65bda83eccaf7bb
diff --git a/sci-mathematics/lean/lean-4.11.0.ebuild b/sci-mathematics/lean/lean-4.11.0.ebuild
new file mode 100644
index 000000000000..88456a89f156
--- /dev/null
+++ b/sci-mathematics/lean/lean-4.11.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MAJOR="$(ver_cut 1)"
+
+CMAKE_MAKEFILE_GENERATOR="emake"
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit cmake flag-o-matic python-any-r1
+
+DESCRIPTION="The Lean Theorem Prover"
+HOMEPAGE="https://leanprover-community.github.io/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/leanprover/${PN}${MAJOR}.git"
+else
+ SRC_URI="https://github.com/leanprover/${PN}${MAJOR}/archive/refs/tags/v${PV/_/-}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}${MAJOR}-${PV/_/-}"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0/${MAJOR}"
+IUSE="debug source"
+
+RDEPEND="
+ dev-libs/gmp:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+"
+
+# Built by lean's build tool.
+QA_FLAGS_IGNORED="usr/lib/lean/libInit_shared.so"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ filter-lto
+
+ sed -e "s|-O[23]|${CFLAGS}|g" -i src/CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local CMAKE_BUILD_TYPE
+
+ if use debug ; then
+ CMAKE_BUILD_TYPE="Debug"
+ else
+ CMAKE_BUILD_TYPE="Release"
+ fi
+
+ local -a mycmakeargs=(
+ -DLEAN_EXTRA_CXX_FLAGS="${CXXFLAGS}"
+ -DLEAN_EXTRA_LINKER_FLAGS="${LDFLAGS}"
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ rm "${ED}/usr/LICENSE"* || die
+
+ if ! use source ; then
+ rm -r "${ED}/usr/src" || die
+ fi
+}