summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2018-03-22 11:21:03 +0100
committerGuilherme Amadio <amadio@gentoo.org>2018-03-22 15:23:30 +0100
commit91e8ffac654ffdb0d29bb35827e6ec0ff7ab977d (patch)
tree889b8dc757d6b5fd7b4583c211f8275f41005bac /sci-physics/root
parentnet-libs/davix: tests need tools to be enabled, bug 651098 (diff)
downloadgentoo-91e8ffac654ffdb0d29bb35827e6ec0ff7ab977d.tar.gz
gentoo-91e8ffac654ffdb0d29bb35827e6ec0ff7ab977d.tar.bz2
gentoo-91e8ffac654ffdb0d29bb35827e6ec0ff7ab977d.zip
Revert "sci-physics/root: have root6 compile on Prefix."
This reverts commit 0fa97fd6f71bb38beb26c4015a1bf6b02d6207d3. This broke the build with USE=opengl.
Diffstat (limited to 'sci-physics/root')
-rw-r--r--sci-physics/root/files/root-6.12.06-disable-ftgl.patch45
-rw-r--r--sci-physics/root/root-6.12.06-r1.ebuild6
2 files changed, 1 insertions, 50 deletions
diff --git a/sci-physics/root/files/root-6.12.06-disable-ftgl.patch b/sci-physics/root/files/root-6.12.06-disable-ftgl.patch
deleted file mode 100644
index 89d8d550d300..000000000000
--- a/sci-physics/root/files/root-6.12.06-disable-ftgl.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-Forwarded: https://sft.its.cern.ch/jira/browse/ROOT-9315
-
-Index: root-6.12.06/cmake/modules/SearchInstalledSoftware.cmake
-===================================================================
---- root-6.12.06.orig/cmake/modules/SearchInstalledSoftware.cmake
-+++ root-6.12.06/cmake/modules/SearchInstalledSoftware.cmake
-@@ -1075,22 +1075,24 @@ if(globus)
- endif()
-
- #---Check for ftgl if needed----------------------------------------------------------
--if(NOT builtin_ftgl)
-- find_package(FTGL)
-- if(NOT FTGL_FOUND)
-- if(fail-on-missing)
-- message(FATAL_ERROR "ftgl library not found and is required ('builtin_ftgl' is OFF). Set varible FTGL_ROOT_DIR to installation location")
-- else()
-- message(STATUS "ftgl library not found. Set variable FTGL_ROOT_DIR to point to your installation")
-- message(STATUS "For the time being switching ON 'builtin_ftgl' option")
-- set(builtin_ftgl ON CACHE BOOL "" FORCE)
-+if(buildgl)
-+ if(NOT builtin_ftgl)
-+ find_package(FTGL)
-+ if(NOT FTGL_FOUND)
-+ if(fail-on-missing)
-+ message(FATAL_ERROR "ftgl library not found and is required ('builtin_ftgl' is OFF). Set varible FTGL_ROOT_DIR to installation location")
-+ else()
-+ message(STATUS "ftgl library not found. Set variable FTGL_ROOT_DIR to point to your installation")
-+ message(STATUS "For the time being switching ON 'builtin_ftgl' option")
-+ set(builtin_ftgl ON CACHE BOOL "" FORCE)
-+ endif()
- endif()
- endif()
--endif()
--if(builtin_ftgl)
-- set(FTGL_INCLUDE_DIR ${CMAKE_SOURCE_DIR}/graf3d/ftgl/inc)
-- set(FTGL_CFLAGS -DBUILTIN_FTGL)
-- set(FTGL_LIBRARIES FTGL)
-+ if(builtin_ftgl)
-+ set(FTGL_INCLUDE_DIR ${CMAKE_SOURCE_DIR}/graf3d/ftgl/inc)
-+ set(FTGL_CFLAGS -DBUILTIN_FTGL)
-+ set(FTGL_LIBRARIES FTGL)
-+ endif()
- endif()
-
- #---Check for chirp--------------------------------------------------------------------
diff --git a/sci-physics/root/root-6.12.06-r1.ebuild b/sci-physics/root/root-6.12.06-r1.ebuild
index 6f44ce517b4e..c0815302e7df 100644
--- a/sci-physics/root/root-6.12.06-r1.ebuild
+++ b/sci-physics/root/root-6.12.06-r1.ebuild
@@ -9,7 +9,7 @@ CMAKE_MAKEFILE_GENERATOR=emake
FORTRAN_NEEDED="fortran"
PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-inherit cmake-utils elisp-common eutils fortran-2 gnome2-utils prefix \
+inherit cmake-utils elisp-common eutils fortran-2 gnome2-utils \
python-single-r1 toolchain-funcs user versionator xdg-utils
DESCRIPTION="C++ data analysis framework and interpreter from CERN"
@@ -115,7 +115,6 @@ PATCHES=(
"${FILESDIR}"/${PN}-6.11.02-hsimple.patch
"${FILESDIR}"/${PN}-6.12.04-no-ocaml.patch
"${FILESDIR}"/${PN}-6.12.04-z3.patch
- "${FILESDIR}"/${PN}-6.12.06-disable-ftgl.patch
)
pkg_setup() {
@@ -152,8 +151,6 @@ src_prepare() {
# CSS should use local images
sed -i -e 's,http://.*/,,' etc/html/ROOT.css || die "html sed failed"
-
- hprefixify build/CMakeLists.txt core/clingutils/CMakeLists.txt
}
# Note: ROOT uses bundled LLVM, because it is patched and API-incompatible with system LLVM.
@@ -165,7 +162,6 @@ src_configure() {
-DCMAKE_C_FLAGS="${CFLAGS}"
-DCMAKE_CXX_FLAGS="${CXXFLAGS}"
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/${MY_PREFIX}"
- -DDEFAULT_SYSROOT="${EPREFIX}" # for llvm system headers
-Dexplicitlink=ON
-Dexceptions=ON
-Dfail-on-missing=ON