summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-visualization/nonolith-connect
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-visualization/nonolith-connect')
-rw-r--r--sci-visualization/nonolith-connect/Manifest1
-rw-r--r--sci-visualization/nonolith-connect/files/1.0.1-cflags-respect.patch69
-rw-r--r--sci-visualization/nonolith-connect/files/1.1-cflags-respect.patch70
-rw-r--r--sci-visualization/nonolith-connect/files/60-nonolith-connect.rules3
-rwxr-xr-xsci-visualization/nonolith-connect/files/nonolith-connect.initd17
-rw-r--r--sci-visualization/nonolith-connect/metadata.xml9
-rw-r--r--sci-visualization/nonolith-connect/nonolith-connect-1.1.ebuild54
7 files changed, 223 insertions, 0 deletions
diff --git a/sci-visualization/nonolith-connect/Manifest b/sci-visualization/nonolith-connect/Manifest
new file mode 100644
index 000000000000..471b6ca7c6b0
--- /dev/null
+++ b/sci-visualization/nonolith-connect/Manifest
@@ -0,0 +1 @@
+DIST nonolith-connect-1.1.tar.bz2 559686 SHA256 0cfda84d83df4efea7c2c9765a3576fecf92d04dc4fee76397f3843022c2e749 SHA512 41fe49a21a2f773c04c8054f322d17958b3eadac82e7013c50ff73c13dc31baa4905d52c02b5270d636fbb5348aff7ca8b064a30a81e970083abd6e69f93aff9 WHIRLPOOL 5e8f600708e67deda3580185e627f33c77db920e0c99a53c31b476bcde6f625a6ce909d993075a0643d5b0894625da30b0d398b89ae9195e3c086e53b82b7043
diff --git a/sci-visualization/nonolith-connect/files/1.0.1-cflags-respect.patch b/sci-visualization/nonolith-connect/files/1.0.1-cflags-respect.patch
new file mode 100644
index 000000000000..46e0aed1d1f4
--- /dev/null
+++ b/sci-visualization/nonolith-connect/files/1.0.1-cflags-respect.patch
@@ -0,0 +1,69 @@
+--- SConstruct
++++ SConstruct
+@@ -1,7 +1,21 @@
+ import sys, os, shutil
++import SCons.Util
+
+ env = Environment()
+
++if os.environ.has_key('CC'):
++ env['CC'] = os.environ['CC']
++if os.environ.has_key('CFLAGS'):
++ env['CCFLAGS'] += SCons.Util.CLVar(os.environ['CFLAGS'])
++if os.environ.has_key('CXX'):
++ env['CXX'] = os.environ['CXX']
++if os.environ.has_key('CXXFLAGS'):
++ env['CXXFLAGS'] += SCons.Util.CLVar(os.environ['CXXFLAGS'])
++if os.environ.has_key('LDFLAGS'):
++ env['LINKFLAGS'] += SCons.Util.CLVar(os.environ['LDFLAGS'])
++if "$CCFLAGS" in env['CXXCOM']:
++ env['CXXCOM'] = env['CXXCOM'].replace("$CCFLAGS","")
++
+ opts = Variables()
+ opts.Add(BoolVariable("mingwcross", "Cross-compile with mingw for Win32", 0))
+ opts.Add(BoolVariable("boost_static", "Statically link against Boost", 0))
+@@ -101,8 +115,7 @@
+ sources = Glob('*.cpp') + ['cee/cee.cpp', 'bootloader/bootloader.cpp']
+
+ json = env.Library('json',
+- Glob('libjson/Source/*.cpp'),
+- CCFLAGS = "-c -O3 -ffast-math -fexpensive-optimizations".split()
++ Glob('libjson/Source/*.cpp')
+ )
+
+ websocketpp = env.Library('websocketpp', ['websocketpp/src/'+i for i in [
+@@ -113,7 +126,7 @@
+ 'websocket_session.cpp',
+ 'sha1/sha1.cpp',
+ 'base64/base64.cpp'
+- ]], CCFLAGS=['-g', '-O3'])
++ ]])
+
+
+ libusb_cflags = []
+@@ -127,14 +140,21 @@
+ libusb_os = ['os/poll_windows.c', 'os/windows_usb.c', 'os/threads_windows.c']
+ libusb_cflags += ['-D OS_WINDOWS', '-DPOLL_NFDS_TYPE=unsigned int', '-D WINVER=0x0501']
+
+-libusb = env.Library('libusb_nonolith', ['libusb/libusb/'+i for i in [
++env_libusb = env.Clone()
++env_libusb.Append(CPPFLAGS=libusb_cflags)
++env_libusb.Append(CFLAGS=['-Ilibusb', '-Ilibusb/libusb'])
++
++libusb = env_libusb.Library('libusb_nonolith', ['libusb/libusb/'+i for i in [
+ 'core.c',
+ 'descriptor.c',
+ 'io.c',
+ 'sync.c',
+- ]+libusb_os], CFLAGS=['-g', '-O3', '-Ilibusb', '-Ilibusb/libusb']+libusb_cflags)
+-
++ ]+libusb_os])
+
+ libs += boostlibs
+
+-env.Program('nonolith-connect', sources, LIBS=libs, CCFLAGS=['-Wall', '-g', '-O3', '-Ilibusb', '-Iwebsocketpp/src', '-shared', "-DVERSION='%s'"%version], FRAMEWORKS=frameworks)
++env_main = env.Clone()
++env_main.Append(CPPFLAGS=["-DVERSION='%s'"%version])
++env_main.Append(CXXFLAGS=['-Ilibusb', '-Iwebsocketpp/src', '-Wall'])
++#env_main.Append(LINKFLAGS=['-shared'])
++env_main.Program('nonolith-connect', sources, LIBS=libs, FRAMEWORKS=frameworks)
diff --git a/sci-visualization/nonolith-connect/files/1.1-cflags-respect.patch b/sci-visualization/nonolith-connect/files/1.1-cflags-respect.patch
new file mode 100644
index 000000000000..c6b04c5fe339
--- /dev/null
+++ b/sci-visualization/nonolith-connect/files/1.1-cflags-respect.patch
@@ -0,0 +1,70 @@
+diff -uNr nonolith-connect-1.1.ORIG/SConstruct nonolith-connect-1.1/SConstruct
+--- nonolith-connect-1.1.ORIG/SConstruct 2012-03-22 10:02:11.398944187 +0000
++++ nonolith-connect-1.1/SConstruct 2012-03-22 10:05:23.149936839 +0000
+@@ -1,7 +1,21 @@
+ import sys, os, shutil
++import SCons.Util
+
+ env = Environment()
+
++if os.environ.has_key('CC'):
++ env['CC'] = os.environ['CC']
++if os.environ.has_key('CFLAGS'):
++ env['CCFLAGS'] += SCons.Util.CLVar(os.environ['CFLAGS'])
++if os.environ.has_key('CXX'):
++ env['CXX'] = os.environ['CXX']
++if os.environ.has_key('CXXFLAGS'):
++ env['CXXFLAGS'] += SCons.Util.CLVar(os.environ['CXXFLAGS'])
++if os.environ.has_key('LDFLAGS'):
++ env['LINKFLAGS'] += SCons.Util.CLVar(os.environ['LDFLAGS'])
++if "$CCFLAGS" in env['CXXCOM']:
++ env['CXXCOM'] = env['CXXCOM'].replace("$CCFLAGS","")
++
+ opts = Variables()
+ opts.Add(BoolVariable("mingwcross", "Cross-compile with mingw for Win32", 0))
+ opts.Add(BoolVariable("boost_static", "Statically link against Boost", 0))
+@@ -95,8 +109,7 @@
+ sources = Glob('*.cpp') + Glob('streaming_device/*.cpp') + ['cee/cee.cpp', 'bootloader/bootloader.cpp']
+
+ json = env.Library('json',
+- Glob('libjson/Source/*.cpp'),
+- CCFLAGS = "-c -O3 -ffast-math -fexpensive-optimizations".split()
++ Glob('libjson/Source/*.cpp')
+ )
+
+ websocketpp = env.Library('websocketpp', ['websocketpp/src/'+i for i in [
+@@ -107,7 +120,7 @@
+ 'websocket_session.cpp',
+ 'sha1/sha1.cpp',
+ 'base64/base64.cpp'
+- ]], CCFLAGS=['-g', '-O3'])
++ ]])
+
+
+ libusb_cflags = []
+@@ -121,14 +134,22 @@
+ libusb_os = ['os/poll_windows.c', 'os/windows_usb.c', 'os/threads_windows.c']
+ libusb_cflags += ['-D OS_WINDOWS', '-DPOLL_NFDS_TYPE=unsigned int', '-D WINVER=0x0501']
+
+-libusb = env.Library('libusb_nonolith', ['libusb/libusb/'+i for i in [
++env_libusb = env.Clone()
++env_libusb.Append(CPPFLAGS=libusb_cflags)
++env_libusb.Append(CFLAGS=['-Ilibusb', '-Ilibusb/libusb'])
++
++libusb = env_libusb.Library('libusb_nonolith', ['libusb/libusb/'+i for i in [
+ 'core.c',
+ 'descriptor.c',
+ 'io.c',
+ 'sync.c',
+- ]+libusb_os], CFLAGS=['-g', '-O3', '-Ilibusb', '-Ilibusb/libusb']+libusb_cflags)
++ ]+libusb_os])
+
+
+ libs += boostlibs
+
+-env.Program('nonolith-connect', sources, LIBS=libs, CCFLAGS=['-Wall', '-g', '-O3', '-Ilibusb', '-Iwebsocketpp/src', '-shared'], FRAMEWORKS=frameworks)
++env_main = env.Clone()
++env_main.Append(CXXFLAGS=['-Ilibusb', '-Iwebsocketpp/src', '-Wall'])
++#env_main.Append(LINKFLAGS=['-shared'])
++env_main.Program('nonolith-connect', sources, LIBS=libs, FRAMEWORKS=frameworks)
++
diff --git a/sci-visualization/nonolith-connect/files/60-nonolith-connect.rules b/sci-visualization/nonolith-connect/files/60-nonolith-connect.rules
new file mode 100644
index 000000000000..63d44d042f16
--- /dev/null
+++ b/sci-visualization/nonolith-connect/files/60-nonolith-connect.rules
@@ -0,0 +1,3 @@
+SUBSYSTEM=="usb", ATTR{idVendor}=="59e3", ATTR{idProduct}=="cee1", GROUP:="nonolithd", MODE="0666"
+SUBSYSTEM=="usb", ATTR{idVendor}=="59e3", ATTR{idProduct}=="b003", GROUP:="nonolithd", MODE="0666"
+SUBSYSTEM=="usb", ATTR{idVendor}=="59e3", ATTR{idProduct}=="bbbb", GROUP:="nonolithd", MODE="0666"
diff --git a/sci-visualization/nonolith-connect/files/nonolith-connect.initd b/sci-visualization/nonolith-connect/files/nonolith-connect.initd
new file mode 100755
index 000000000000..42ce559b6849
--- /dev/null
+++ b/sci-visualization/nonolith-connect/files/nonolith-connect.initd
@@ -0,0 +1,17 @@
+#!/sbin/runscript
+
+depend() {
+ after logger
+}
+
+start() {
+ ebegin "Starting nonolith-connect"
+ start-stop-daemon --start --quiet -b -m -p /var/run/nonolith-connect.pid -u nonolithd:usb --exec /usr/bin/nonolith-connect
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping nonolith-connect"
+ start-stop-daemon --stop --quiet -p /var/run/nonolith-connect.pid
+ eend $?
+}
diff --git a/sci-visualization/nonolith-connect/metadata.xml b/sci-visualization/nonolith-connect/metadata.xml
new file mode 100644
index 000000000000..f14f39732531
--- /dev/null
+++ b/sci-visualization/nonolith-connect/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>chainsaw@gentoo.org</email>
+ <name>Tony Vroon</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-visualization/nonolith-connect/nonolith-connect-1.1.ebuild b/sci-visualization/nonolith-connect/nonolith-connect-1.1.ebuild
new file mode 100644
index 000000000000..19ded55ce79a
--- /dev/null
+++ b/sci-visualization/nonolith-connect/nonolith-connect-1.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils scons-utils toolchain-funcs user
+
+DESCRIPTION="CEE (Control - Experiment - Explore) analog multitool"
+HOMEPAGE="http://www.nonolithlabs.com/cee/"
+SRC_URI="http://apps.nonolithlabs.com/download/source/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost
+ virtual/udev"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PV}-cflags-respect.patch" )
+
+pkg_setup() {
+ tc-export CC CXX
+ enewuser nonolithd -1 -1 /dev/null usb
+}
+
+src_prepare() {
+ epatch ${PATCHES[@]}
+}
+
+src_configure() {
+ myesconsargs=(
+ boost_static=0
+ )
+}
+
+src_compile() {
+ escons
+}
+
+src_install() {
+ dobin nonolith-connect
+ newinitd "${FILESDIR}"/nonolith-connect.initd nonolith-connect
+}
+
+pkg_postinst() {
+ einfo "Consider adding nonolith-connect to the default runlevel."
+ einfo "Please connect your CEE hardware, start nonolith-connect "
+ einfo "using the init script provided and then visit:"
+ einfo "http://apps.nonolithlabs.com/setup"
+}