summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/ccs-tools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/ccs-tools')
-rw-r--r--sys-apps/ccs-tools/Manifest1
-rw-r--r--sys-apps/ccs-tools/ccs-tools-1.8.3_p20130214.ebuild62
-rw-r--r--sys-apps/ccs-tools/files/ccs-tools-1.8.3_p20130214-warnings.patch22
-rw-r--r--sys-apps/ccs-tools/metadata.xml10
4 files changed, 95 insertions, 0 deletions
diff --git a/sys-apps/ccs-tools/Manifest b/sys-apps/ccs-tools/Manifest
new file mode 100644
index 000000000000..5468277006dd
--- /dev/null
+++ b/sys-apps/ccs-tools/Manifest
@@ -0,0 +1 @@
+DIST ccs-tools-1.8.3-20130214.tar.gz 227657 SHA256 56bb03f1977346f4c7dc3a0c5da8df4a0451a79558c26564478cb87fbf3e3ade SHA512 256adf873dd99b811f5cf55e6b74e1ccdc2e54a2399724b694f22825c4d5e3167e7768bddc4952363ef835ec2b8405d5704572a9b9e214f3102bf594374325ba WHIRLPOOL d7f200842a10ca2c83a46a933beb7c70436ea36c8aad3569c33392a11360b88dbf7589ac720994fec9d5c49c46f1e1c9f97ec320d2057680a6bb0edf13c066eb
diff --git a/sys-apps/ccs-tools/ccs-tools-1.8.3_p20130214.ebuild b/sys-apps/ccs-tools/ccs-tools-1.8.3_p20130214.ebuild
new file mode 100644
index 000000000000..dcdc98ae6690
--- /dev/null
+++ b/sys-apps/ccs-tools/ccs-tools-1.8.3_p20130214.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+inherit eutils multilib toolchain-funcs
+
+MY_P="${P/_p/-}"
+DESCRIPTION="TOMOYO Linux tools"
+HOMEPAGE="http://tomoyo.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/tomoyo/49693/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT="test"
+
+DEPEND="sys-libs/ncurses
+ sys-libs/readline"
+RDEPEND="${DEPEND}
+ sys-apps/which"
+
+S="${WORKDIR}/ccs-tools"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-warnings.patch
+ sed -i \
+ -e "s:gcc:$(tc-getCC):" \
+ -e "s/\(CFLAGS.*:=\).*/\1 ${CFLAGS}/" \
+ -e "s:/usr/lib:/usr/$(get_libdir):g" \
+ -e "s:= /:= ${EPREFIX}/:g" \
+ Include.make || die
+}
+
+src_test() {
+ cd "${S}/kernel_test"
+ emake || die
+ ./testall.sh || die
+}
+
+src_install() {
+ emake INSTALLDIR="${D}" install || die
+ dodoc README.ccs
+}
+
+pkg_postinst() {
+ elog "Execute the following command to setup the initial policy configuration:"
+ elog
+ elog "emerge --config =${CATEGORY}/${PF}"
+ elog
+ elog "For more information, please visit http://tomoyo.sourceforge.jp/1.8/"
+ elog
+ elog "This tools are for ccs-patch'ed kernels. There are also sys-apps/tomoyo-tools"
+ elog "which works with TOMOYO 2.x.x versions (already merged into Linux kernel)."
+ elog "If you'd like to try them, please emerge sys-apps/tomoyo-tools instead."
+}
+
+pkg_config() {
+ /usr/$(get_libdir)/ccs/init_policy
+}
diff --git a/sys-apps/ccs-tools/files/ccs-tools-1.8.3_p20130214-warnings.patch b/sys-apps/ccs-tools/files/ccs-tools-1.8.3_p20130214-warnings.patch
new file mode 100644
index 000000000000..8201093bbecb
--- /dev/null
+++ b/sys-apps/ccs-tools/files/ccs-tools-1.8.3_p20130214-warnings.patch
@@ -0,0 +1,22 @@
+diff --git a/usr_sbin/editpolicy_offline.c b/usr_sbin/editpolicy_offline.c
+index dbbd11e..e699cf4 100644
+--- a/usr_sbin/editpolicy_offline.c
++++ b/usr_sbin/editpolicy_offline.c
+@@ -2882,7 +2882,7 @@ static bool ccs_parse_ipaddr_union(struct ccs_acl_param *param,
+ struct ccs_ipaddr_union *ptr)
+ {
+ struct ccs_ip_address_entry e;
+- memset(ptr, 0, sizeof(ptr));
++ memset(ptr, 0, sizeof(*ptr));
+ if (ccs_parse_ip(ccs_read_token(param), &e) == 0) {
+ memmove(&ptr->ip[0], e.min, sizeof(ptr->ip[0]));
+ memmove(&ptr->ip[1], e.max, sizeof(ptr->ip[1]));
+@@ -4745,7 +4745,7 @@ static void ccs_write_control(char *buffer, const size_t buffer_len)
+ *
+ * Returns nothing.
+ */
+-static void ccs_editpolicy_offline_init(coid)
++static void ccs_editpolicy_offline_init(void)
+ {
+ static _Bool first = true;
+ int i;
diff --git a/sys-apps/ccs-tools/metadata.xml b/sys-apps/ccs-tools/metadata.xml
new file mode 100644
index 000000000000..01cfb2cab229
--- /dev/null
+++ b/sys-apps/ccs-tools/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge-jp">tomoyo</remote-id>
+ </upstream>
+</pkgmetadata>