summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-07 04:45:56 +0100
committerSam James <sam@gentoo.org>2022-04-07 04:57:16 +0100
commit0e5cbc3642670e7741a551eb4775fcdc8694cd10 (patch)
tree93b031c156ca46e964868c5e339695d323448500 /sys-apps/coreutils/coreutils-9.0-r2.ebuild
parentsec-keys/openpgp-keys-coreutils: new package, add 20220407 (diff)
downloadgentoo-0e5cbc3642670e7741a551eb4775fcdc8694cd10.tar.gz
gentoo-0e5cbc3642670e7741a551eb4775fcdc8694cd10.tar.bz2
gentoo-0e5cbc3642670e7741a551eb4775fcdc8694cd10.zip
sys-apps/coreutils: add verify-sig
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/coreutils/coreutils-9.0-r2.ebuild')
-rw-r--r--sys-apps/coreutils/coreutils-9.0-r2.ebuild17
1 files changed, 14 insertions, 3 deletions
diff --git a/sys-apps/coreutils/coreutils-9.0-r2.ebuild b/sys-apps/coreutils/coreutils-9.0-r2.ebuild
index c8d7eca8e649..e55e9bf82f73 100644
--- a/sys-apps/coreutils/coreutils-9.0-r2.ebuild
+++ b/sys-apps/coreutils/coreutils-9.0-r2.ebuild
@@ -4,8 +4,8 @@
EAPI=7
PYTHON_COMPAT=( python3_{8..10} )
-
-inherit flag-o-matic python-any-r1 toolchain-funcs
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/coreutils.asc
+inherit flag-o-matic python-any-r1 toolchain-funcs verify-sig
PATCH="${PN}-8.30-patches-01"
DESCRIPTION="Standard GNU utilities (chmod, cp, dd, ls, sort, tr, head, wc, who,...)"
@@ -14,7 +14,8 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
!vanilla? (
mirror://gentoo/${PATCH}.tar.xz
https://dev.gentoo.org/~polynomial-c/dist/${PATCH}.tar.xz
- )"
+ )
+ verify-sig? ( mirror://gnu/${PN}/${P}.tar.xz.sig )"
LICENSE="GPL-3"
SLOT="0"
@@ -42,6 +43,7 @@ BDEPEND="
dev-util/strace
${PYTHON_DEPS}
)
+ verify-sig? ( sec-keys/openpgp-keys-coreutils )
"
RDEPEND+="
hostname? ( !sys-apps/net-tools[hostname] )
@@ -64,6 +66,15 @@ pkg_setup() {
fi
}
+src_unpack() {
+ if use verify-sig ; then
+ # Needed for downloaded patch (which is unsigned, which is fine)
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.xz{,.sig}
+ fi
+
+ default
+}
+
src_prepare() {
local PATCHES=(
# Upstream patches