summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlice Ferrazzi <alicef@gentoo.org>2019-07-04 18:48:59 +0000
committerAlice Ferrazzi <alicef@gentoo.org>2019-07-04 19:06:57 +0000
commitaf3eb37e207a0b63bc7050612622d9f683506a8b (patch)
tree14e920d46b2235f8c83404cd3c4ac8466a893465 /sys-apps/elivepatch-server
parentdev-ruby/domain_name: stable 0.5.20180417 for hppa, bug #684546 (diff)
downloadgentoo-af3eb37e207a0b63bc7050612622d9f683506a8b.tar.gz
gentoo-af3eb37e207a0b63bc7050612622d9f683506a8b.tar.bz2
gentoo-af3eb37e207a0b63bc7050612622d9f683506a8b.zip
sys-apps/elivepatch-server: bump to 0.2
Package-Manager: Portage-2.3.66, Repoman-2.3.11 Signed-off-by: Alice Ferrazzi <alicef@gentoo.org>
Diffstat (limited to 'sys-apps/elivepatch-server')
-rw-r--r--sys-apps/elivepatch-server/Manifest1
-rw-r--r--sys-apps/elivepatch-server/elivepatch-server-0.2.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/sys-apps/elivepatch-server/Manifest b/sys-apps/elivepatch-server/Manifest
index 7f020d448e25..5ac76676c92f 100644
--- a/sys-apps/elivepatch-server/Manifest
+++ b/sys-apps/elivepatch-server/Manifest
@@ -1 +1,2 @@
DIST elivepatch-server-0.1.tar.gz 11564 BLAKE2B 0b1a9c518ba51ffa4fcdf0d5d0202b182464d13123334583e8f647be4c8ff48c9d7471fcab8a18d2ddd27172928942e4645c75a1976b25a521c7f1caecedb0b6 SHA512 d469fbc32df7a586fa899c6e587832bd53c1984c97b973e3aad4f6bf62962846142938a6e6e5729fce39d3f7d486c5ed9fd9f484425d863a40a1199f170830fb
+DIST elivepatch-server-0.2.tar.gz 14198 BLAKE2B 1e48626dff5cf0ed5e7e3fb09dec54fc0e203be58646a62419df901c8b96964281250c613ef06cca9ede32ce7f4e384094892a79033afa0d20b133c54a4cc5c6 SHA512 1af4c6656b32491d82c0c98ed53a7184bea4a2639d6bf6072c3e8ae3f0d12c09284cdb6f96129b1ce848872946e14c6b83d3bbe6eb959cd5c918575ed42a621a
diff --git a/sys-apps/elivepatch-server/elivepatch-server-0.2.ebuild b/sys-apps/elivepatch-server/elivepatch-server-0.2.ebuild
new file mode 100644
index 000000000000..5707a104f427
--- /dev/null
+++ b/sys-apps/elivepatch-server/elivepatch-server-0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Live patch building server with RESTFul Api for elivepatch-client"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Elivepatch"
+SRC_URI="https://github.com/aliceinwire/elivepatch-server/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-restful[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ newinitd init/elivepatch.init ${PN}
+ newconfd init/elivepatch.confd ${PN}
+ distutils-r1_python_install_all
+}