summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-01-26 18:30:28 -0500
committerMike Gilbert <floppym@gentoo.org>2020-01-26 18:33:03 -0500
commitbcb11aec5a7c5d40753e40482dc4cd12cf247bec (patch)
treeb3acbb8200d4bf7036b72bee561028ecca52f48e /sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
parentapp-text/editorconfig-core-c: Add missing slash to fix CI (diff)
downloadgentoo-bcb11aec5a7c5d40753e40482dc4cd12cf247bec.tar.gz
gentoo-bcb11aec5a7c5d40753e40482dc4cd12cf247bec.tar.bz2
gentoo-bcb11aec5a7c5d40753e40482dc4cd12cf247bec.zip
sys-apps/gentoo-functions: bump to 0.13
Package-Manager: Portage-2.3.85_p2, Repoman-2.3.20_p36 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps/gentoo-functions/gentoo-functions-9999.ebuild')
-rw-r--r--sys-apps/gentoo-functions/gentoo-functions-9999.ebuild20
1 files changed, 9 insertions, 11 deletions
diff --git a/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild b/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
index a8780922f9d2..3c1089a7586b 100644
--- a/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
+++ b/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
@@ -1,30 +1,28 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
if [[ ${PV} == 9999* ]]; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/gentoo/${PN}.git"
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-functions.git"
else
- SRC_URI="https://github.com/gentoo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+ SRC_URI="https://gitweb.gentoo.org/proj/gentoo-functions.git/snapshot/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
fi
inherit toolchain-funcs flag-o-matic
DESCRIPTION="base functions required by all Gentoo systems"
-HOMEPAGE="https://www.gentoo.org"
+HOMEPAGE="https://gitweb.gentoo.org/proj/gentoo-functions.git"
LICENSE="GPL-2"
SLOT="0"
IUSE=""
-src_prepare() {
+src_configure() {
tc-export CC
append-lfs-flags
-}
-
-src_install() {
- emake install DESTDIR="${ED}"
+ export ROOTPREFIX="${EPREFIX}"
+ export PREFIX="${EPREFIX}/usr"
}