summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2023-10-02 21:20:07 +0200
committerConrad Kostecki <conikost@gentoo.org>2023-10-02 21:32:10 +0200
commitd7ef9828b5e999bca6443d71afcf13a9b8d250cc (patch)
treee6e508393c6304de1b59f315a38f9bd590796341 /sys-apps/hw-probe
parentapp-benchmarks/geekbench: add 6.2.1, drop 6.2.0 (diff)
downloadgentoo-d7ef9828b5e999bca6443d71afcf13a9b8d250cc.tar.gz
gentoo-d7ef9828b5e999bca6443d71afcf13a9b8d250cc.tar.bz2
gentoo-d7ef9828b5e999bca6443d71afcf13a9b8d250cc.zip
sys-apps/hw-probe: add 1.6.5_p20230812
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-apps/hw-probe')
-rw-r--r--sys-apps/hw-probe/Manifest1
-rw-r--r--sys-apps/hw-probe/hw-probe-1.6.5_p20230812.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/sys-apps/hw-probe/Manifest b/sys-apps/hw-probe/Manifest
index 7202da398968..add35bbc8d0e 100644
--- a/sys-apps/hw-probe/Manifest
+++ b/sys-apps/hw-probe/Manifest
@@ -1 +1,2 @@
DIST hw-probe-1.6.5.tar.gz 163190 BLAKE2B 1d2ceb152d387018f427cd623897f8c4cc8828a6952c54bb9caa673797ac347b64d9daffcddeca16e8274e5ad42c2cff22efe3330209da1eee5476636167f0ad SHA512 68d6709ca4efe82e0e5de3b580c68f76fa31384af0c53645b6609cee14b944a410e58b12ac13f879d8d86220c1088cfaad17dc6edd24cf27700e449add6f6488
+DIST hw-probe-1.6.5_p20230812.tar.gz 166015 BLAKE2B 1c5e3ab58aa28e1d5a757d75e8b462b7eaf3da1eb4baca308c681000b95c333e8ea3141b9af2a28e8453a449ea38cca9f5239996e216c0c7dfc4414fc8781b8a SHA512 633cda1e1d6a3104587b6ebf4faad98526e0d6daec5e9a26b319a4b5b76baeac063277eca9e81e7903b28cdebbb3db095f7526d1f46511f885e37b31e1032b7d
diff --git a/sys-apps/hw-probe/hw-probe-1.6.5_p20230812.ebuild b/sys-apps/hw-probe/hw-probe-1.6.5_p20230812.ebuild
new file mode 100644
index 000000000000..c04d163ed62c
--- /dev/null
+++ b/sys-apps/hw-probe/hw-probe-1.6.5_p20230812.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+EGIT_COMMIT="b895b77b7e03f4b1b0a5fb177118373ee0328a25"
+
+inherit optfeature readme.gentoo-r1
+
+DESCRIPTION="A tool to probe for hardware, check it's operability and find drivers"
+HOMEPAGE="https://github.com/linuxhw/hw-probe/"
+SRC_URI="https://github.com/linuxhw/hw-probe/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Digest-SHA1
+ net-misc/curl
+ sys-apps/dmidecode
+ sys-apps/edid-decode
+ sys-apps/hwinfo
+ sys-apps/pciutils
+ sys-apps/smartmontools
+ sys-apps/usbutils
+ virtual/perl-Data-Dumper
+"
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ default
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ optfeature "showing Machine Check Exceptions." app-admin/mcelog
+ optfeature "showing additional I/O statistics." app-admin/sysstat
+ optfeature "showing display data channel (ddc) information." app-misc/ddcutil
+ optfeature "showing smart card (reader) information." dev-libs/opensc
+ optfeature "showing Vulkan GPU hardware information." dev-util/vulkan-tools
+ optfeature "showing information of attached scanners." media-gfx/sane-backends
+ optfeature "showing GPU information provided by MESA." media-libs/mesa
+ optfeature "showing zeroconf statistics." net-dns/avahi
+ optfeature "showing HP printer statistics." net-print/hplip
+ optfeature "showing status about rfkill switches on communication devices." net-wireless/rfkill
+ optfeature "showing additional CPU capabilities." sys-apps/cpuid
+ optfeature "showing hard disk (HDD, SSD, ..) capabilities." sys-apps/hdparm
+ optfeature "showing available I2C sensors." sys-apps/i2c-tools
+ optfeature "showing additional hardware and system information detected by inxi." sys-apps/inxi
+ optfeature "showing information about tested memory for faults." sys-apps/memtester
+ optfeature "showing 'Plug & Play' devices." sys-apps/pnputils
+ optfeature "showing systemd boot process information." sys-apps/systemd
+ optfeature "showing ACPI statistics and tables." sys-power/iasl
+ optfeature "showing information about NUMA." sys-process/numactl
+ optfeature "showing additional GPU information provided by MESA progs." x11-apps/mesa-progs
+ optfeature "showing available Xinput devices." x11-apps/xinput
+}