summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-04-25 10:45:15 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-04-25 10:48:24 +0200
commit21867382426ea87eccf3c49ece762b4e83589edd (patch)
tree0a5d526a5c35f04a0340def87c852e5b99b3246d /sys-apps/hwloc
parentx11-drivers/nvidia-drivers: add 550.40.61:0/vulkan, drop 550.40.59 (diff)
downloadgentoo-21867382426ea87eccf3c49ece762b4e83589edd.tar.gz
gentoo-21867382426ea87eccf3c49ece762b4e83589edd.tar.bz2
gentoo-21867382426ea87eccf3c49ece762b4e83589edd.zip
sys-apps/hwloc: remove automagic behaviour of rocm/l0
And: - fixed the icon file - add doc flag to install doxygen documentation Closes: https://bugs.gentoo.org/926862 Closes: https://bugs.gentoo.org/927627 Closes: https://bugs.gentoo.org/833345 Closes: https://bugs.gentoo.org/836663 Closes: https://github.com/gentoo/gentoo/pull/25837 Co-authored-by: Alessandro Barbieri <lssndrbarbieri@gmail.com> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sys-apps/hwloc')
-rw-r--r--sys-apps/hwloc/hwloc-2.9.3-r1.ebuild (renamed from sys-apps/hwloc/hwloc-2.9.3.ebuild)13
-rw-r--r--sys-apps/hwloc/metadata.xml2
2 files changed, 13 insertions, 2 deletions
diff --git a/sys-apps/hwloc/hwloc-2.9.3.ebuild b/sys-apps/hwloc/hwloc-2.9.3-r1.ebuild
index ed032f53b9ab..4d0252d24ecc 100644
--- a/sys-apps/hwloc/hwloc-2.9.3.ebuild
+++ b/sys-apps/hwloc/hwloc-2.9.3-r1.ebuild
@@ -16,7 +16,7 @@ SRC_URI="
LICENSE="BSD"
SLOT="0/15"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="cairo +cpuid cuda debug nvml +pci static-libs svg udev valgrind xml X video_cards_nvidia"
+IUSE="cairo +cpuid cuda debug doc l0 nvml +pci rocm static-libs svg udev valgrind xml X video_cards_nvidia"
# opencl: opencl support dropped with x11-drivers/ati-drivers being removed (bug #582406).
# anyone with hardware is welcome to step up and help test to get it re-added.
@@ -25,11 +25,14 @@ RDEPEND="
>=sys-libs/ncurses-5.9-r3:=[${MULTILIB_USEDEP}]
cairo? ( >=x11-libs/cairo-1.12.14-r4[X?,svg(+)?,${MULTILIB_USEDEP}] )
cuda? ( >=dev-util/nvidia-cuda-toolkit-6.5.19-r1:= )
+ doc? ( app-text/doxygen )
+ l0? ( dev-libs/level-zero:= )
nvml? ( x11-drivers/nvidia-drivers[${MULTILIB_USEDEP}] )
pci? (
>=sys-apps/pciutils-3.3.0-r2[${MULTILIB_USEDEP}]
>=x11-libs/libpciaccess-0.13.1-r1[${MULTILIB_USEDEP}]
)
+ rocm? ( dev-util/rocm-smi:= )
udev? ( virtual/libudev:= )
xml? ( >=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}] )
video_cards_nvidia? (
@@ -86,9 +89,13 @@ multilib_src_configure() {
--runstatedir="${EPREFIX}/run"
$(multilib_native_use_enable cuda)
$(multilib_native_use_enable video_cards_nvidia gl)
+ $(multilib_native_use_enable l0 levelzero)
+ $(multilib_native_use_enable rocm rsmi)
+ $(multilib_native_use_with rocm rocm "${ESYSROOT}/usr")
$(use_enable cairo)
$(use_enable cpuid)
$(use_enable debug)
+ $(use_enable doc doxygen)
$(use_enable udev libudev)
$(use_enable nvml)
$(use_enable pci)
@@ -110,11 +117,13 @@ multilib_src_install_all() {
;;
esac
+ use doc && dodoc -r doc/doxygen-doc/html
+
mv "${ED}"/usr/share/bash-completion/completions/hwloc{,-annotate} || die
bashcomp_alias hwloc-annotate \
hwloc-{diff,ps,compress-dir,gather-cpuid,distrib,info,bind,patch,calc,ls,gather-topology}
bashcomp_alias hwloc-annotate lstopo{,-no-graphics}
find "${ED}" -name '*.la' -delete || die
- newicon "${DISTDIR}/lstopo.png" "${PN}"
+ newicon -s 512 "${DISTDIR}/lstopo.png" ${PN}.png
}
diff --git a/sys-apps/hwloc/metadata.xml b/sys-apps/hwloc/metadata.xml
index 083b6957c7ac..fc998e164476 100644
--- a/sys-apps/hwloc/metadata.xml
+++ b/sys-apps/hwloc/metadata.xml
@@ -18,10 +18,12 @@
<flag name="cpuid">Enable the cpuid-based architecture specific support (x86 component)</flag>
<flag name="cuda">Enable CUDA device discovery using libcudart</flag>
<flag name="gl">Enable GL display device discovery (NVCtrl)</flag>
+ <flag name="l0">Enable oneAPI Level Zero device discovery</flag>
<flag name="numa">Add support for numa memory allocation</flag>
<flag name="nvml">Enable the NVML device discovery</flag>
<flag name="pci">Enable PCI device discovery using libpci</flag>
<flag name="plugins">Build hwloc components as plugins so that the hwloc core library does not directly depend on their dependencies (for instance the libpci library)</flag>
+ <flag name="rocm">Enable AMD RSMI device discovery</flag>
<flag name="xml">use libxml2 for XML support, instead of a custom minimalistic support</flag>
<flag name="X">use the X Window System</flag>
</use>