summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-01 19:58:39 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-01 20:02:13 +0100
commitc5fd7edc168d5365a04392a37ec4812c4e603aa0 (patch)
treea4793c13d5871edb851a998b02a9639604426459 /sys-apps/i2c-tools
parentsci-libs/tensorflow: Fix Python dependencies (diff)
downloadgentoo-c5fd7edc168d5365a04392a37ec4812c4e603aa0.tar.gz
gentoo-c5fd7edc168d5365a04392a37ec4812c4e603aa0.tar.bz2
gentoo-c5fd7edc168d5365a04392a37ec4812c4e603aa0.zip
sys-apps/i2c-tools: Fix Python dependencies
DISTUTILS_USE_SETUPTOOLS is not used with DISTUTILS_OPTIONAL, the dep on setuptools needs to be declared explicitly. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-apps/i2c-tools')
-rw-r--r--sys-apps/i2c-tools/i2c-tools-4.3.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/sys-apps/i2c-tools/i2c-tools-4.3.ebuild b/sys-apps/i2c-tools/i2c-tools-4.3.ebuild
index 08557d67f1fa..1b4f3d12d061 100644
--- a/sys-apps/i2c-tools/i2c-tools-4.3.ebuild
+++ b/sys-apps/i2c-tools/i2c-tools-4.3.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python{3_8,3_9} )
DISTUTILS_OPTIONAL="1"
-DISTUTILS_USE_SETUPTOOLS=bdepend
inherit distutils-r1 flag-o-matic toolchain-funcs
@@ -21,7 +20,11 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}"
+BDEPEND="
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ )"
src_prepare() {
default