summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-03-28 22:17:43 +0300
committerMart Raudsepp <leio@gentoo.org>2017-03-28 22:38:23 +0300
commite0730154b856798afaf57b044e90c77ca80a11f2 (patch)
treecc74cf6e70cb507ca79adba6ff1f1cdb93eda1aa /sys-apps/osinfo-db-tools/osinfo-db-tools-1.1.0.ebuild
parentdev-python/html5lib: fix sanitizer patch to match upstream (diff)
downloadgentoo-e0730154b856798afaf57b044e90c77ca80a11f2.tar.gz
gentoo-e0730154b856798afaf57b044e90c77ca80a11f2.tar.bz2
gentoo-e0730154b856798afaf57b044e90c77ca80a11f2.zip
sys-apps/osinfo-db-tools: initial package after split from sys-libs/libosinfo
Gentoo-bug: 605124
Diffstat (limited to 'sys-apps/osinfo-db-tools/osinfo-db-tools-1.1.0.ebuild')
-rw-r--r--sys-apps/osinfo-db-tools/osinfo-db-tools-1.1.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-apps/osinfo-db-tools/osinfo-db-tools-1.1.0.ebuild b/sys-apps/osinfo-db-tools/osinfo-db-tools-1.1.0.ebuild
new file mode 100644
index 000000000000..02df94a14cf3
--- /dev/null
+++ b/sys-apps/osinfo-db-tools/osinfo-db-tools-1.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2
+
+DESCRIPTION="Tools for managing the osinfo database"
+HOMEPAGE="http://libosinfo.org/"
+SRC_URI="https://releases.pagure.org/libosinfo/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+# Blocker on old libosinfo as osinfo-db-validate was part of it before
+RDEPEND="
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/libxml2-2.6.0
+ >=app-arch/libarchive-3.0.0:=
+ !<sys-libs/libosinfo-1.0.0
+"
+# perl dep is for pod2man
+# libxslt is checked for in configure.ac, but never used in 1.1.0
+DEPEND="${RDEPEND}
+ >=dev-libs/libxslt-1.0.0
+ virtual/pkgconfig
+ >=dev-util/intltool-0.40.0
+ dev-lang/perl
+"