summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-05-10 15:04:18 -0500
committerTim Harder <radhermit@gentoo.org>2019-05-10 15:06:20 -0500
commit58eb051f00499dbda204c9320f993678518cd198 (patch)
treed44f259b2d015b8e622c64cb21a5e65301504005 /sys-apps/pick/pick-3.0.1.ebuild
parentapp-admin/lnav: version bump to 0.8.5 (diff)
downloadgentoo-58eb051f00499dbda204c9320f993678518cd198.tar.gz
gentoo-58eb051f00499dbda204c9320f993678518cd198.tar.bz2
gentoo-58eb051f00499dbda204c9320f993678518cd198.zip
sys-apps/pick: version bump to 3.0.1
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'sys-apps/pick/pick-3.0.1.ebuild')
-rw-r--r--sys-apps/pick/pick-3.0.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/pick/pick-3.0.1.ebuild b/sys-apps/pick/pick-3.0.1.ebuild
new file mode 100644
index 000000000000..15898cb11a03
--- /dev/null
+++ b/sys-apps/pick/pick-3.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="a fuzzy search tool for the command-line"
+HOMEPAGE="https://github.com/mptre/pick"
+SRC_URI="https://github.com/mptre/pick/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ # not autoconf
+ ./configure || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" BINDIR=/usr/bin MANDIR=/usr/share/man install
+ dodoc CHANGELOG.md
+}