summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-20 23:36:46 +0000
committerSam James <sam@gentoo.org>2022-11-20 23:37:12 +0000
commit1d184f1a99a9bbf53b1fc0f288300ed1979099f2 (patch)
tree578883c8798c57ca58e11a7fe6bde9225b159b1b /sys-apps/portage
parentdev-python/click-help-colors: switch to PEP-517 mode (diff)
downloadgentoo-1d184f1a99a9bbf53b1fc0f288300ed1979099f2.tar.gz
gentoo-1d184f1a99a9bbf53b1fc0f288300ed1979099f2.tar.bz2
gentoo-1d184f1a99a9bbf53b1fc0f288300ed1979099f2.zip
sys-apps/portage: make Portage less noisy on implicit func. decls for now
We will undo this again soon, but we need fewer high profiles to be broken first, as it impacts wider testing & bug finding. Bug: https://bugs.gentoo.org/870412 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/portage')
-rw-r--r--sys-apps/portage/files/portage-3.0.39-implicit-func-decls-no-fatal.patch34
-rw-r--r--sys-apps/portage/portage-3.0.39-r1.ebuild (renamed from sys-apps/portage/portage-3.0.39.ebuild)1
2 files changed, 35 insertions, 0 deletions
diff --git a/sys-apps/portage/files/portage-3.0.39-implicit-func-decls-no-fatal.patch b/sys-apps/portage/files/portage-3.0.39-implicit-func-decls-no-fatal.patch
new file mode 100644
index 000000000000..4a4e68f2690a
--- /dev/null
+++ b/sys-apps/portage/files/portage-3.0.39-implicit-func-decls-no-fatal.patch
@@ -0,0 +1,34 @@
+https://github.com/gentoo/portage/commit/0fdbbbdb5a80e331adf701f2b2c1f096695447c4
+
+From 0fdbbbdb5a80e331adf701f2b2c1f096695447c4 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 20 Nov 2022 23:32:08 +0000
+Subject: [PATCH] install-qa-check.d/90gcc-warnings: don't make implicit func
+ decls fatal for now
+
+We need to do this at some point (as Clang 16 and GCC 14 are doing it, and
+they indicate runtime problems anyway), but there's too much breakage for now.
+
+We did find some extra bugs though. The main issue is too much high-profile
+stuff breaks rather than the total number of bugs, wrt Portage behaviour
+changing being suitable or not.
+
+Bug: https://bugs.gentoo.org/870412
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/bin/install-qa-check.d/90gcc-warnings
++++ b/bin/install-qa-check.d/90gcc-warnings
+@@ -153,9 +153,10 @@ gcc_warn_check() {
+ # always_overflow=yes
+ #fi
+
+- if [[ ${f} == *'[-Wimplicit-function-declaration]'* ]] ; then
+- implicit_func_decl=yes
+- fi
++ # Disabled for now because too many failures. bug #870412.
++ #if [[ ${f} == *'[-Wimplicit-function-declaration]'* ]] ; then
++ # implicit_func_decl=yes
++ #fi
+
+ if [[ ${always_overflow} = yes || ${implicit_func_decl} = yes ]] ; then
+ eerror
+
diff --git a/sys-apps/portage/portage-3.0.39.ebuild b/sys-apps/portage/portage-3.0.39-r1.ebuild
index 48ca5c0728ae..040a60847373 100644
--- a/sys-apps/portage/portage-3.0.39.ebuild
+++ b/sys-apps/portage/portage-3.0.39-r1.ebuild
@@ -85,6 +85,7 @@ pkg_pretend() {
python_prepare_all() {
local PATCHES=(
+ "${FILESDIR}"/${P}-implicit-func-decls-no-fatal.patch
)
distutils-r1_python_prepare_all