summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-05-28 09:20:35 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-05-28 09:20:53 +0100
commit6fac7e1d3121a0611a11f66d945e65806bbae301 (patch)
tree0404d56c13099161f028764fb9593279fe6e00d3 /sys-apps/prctl/prctl-1.6-r1.ebuild
parentdev-python/cffi: Replace virtual/cffi (diff)
downloadgentoo-6fac7e1d3121a0611a11f66d945e65806bbae301.tar.gz
gentoo-6fac7e1d3121a0611a11f66d945e65806bbae301.tar.bz2
gentoo-6fac7e1d3121a0611a11f66d945e65806bbae301.zip
sys-apps/prctl: drop CPP detection
While at it modernized build system up to recent automake. Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-apps/prctl/prctl-1.6-r1.ebuild')
-rw-r--r--sys-apps/prctl/prctl-1.6-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-apps/prctl/prctl-1.6-r1.ebuild b/sys-apps/prctl/prctl-1.6-r1.ebuild
new file mode 100644
index 000000000000..419cae89d00f
--- /dev/null
+++ b/sys-apps/prctl/prctl-1.6-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Tool to query and modify process behavior"
+HOMEPAGE="https://sourceforge.net/projects/prctl/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+PATCHES=(
+ "${FILESDIR}"/${P}-no-implicits.patch
+)
+
+src_prepare() {
+ default
+
+ cp "${FILESDIR}"/{Makefile.am,configure.ac} ./ || die
+ eautoreconf
+}