summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Davies <jpds@protonmail.com>2021-10-24 12:52:21 +0100
committerSam James <sam@gentoo.org>2021-10-31 02:50:23 +0000
commit3cdef6b4b412bbe52869d67e732456f6661241f9 (patch)
treeeaa59772a5bd1a06f072eeb1a40a676be356575b /sys-apps/restorecond
parentsys-apps/policycoreutils: Version updated to 3.3. (diff)
downloadgentoo-3cdef6b4b412bbe52869d67e732456f6661241f9.tar.gz
gentoo-3cdef6b4b412bbe52869d67e732456f6661241f9.tar.bz2
gentoo-3cdef6b4b412bbe52869d67e732456f6661241f9.zip
sys-apps/restorecond: Version updated to 3.3.
Signed-off-by: Jonathan Davies <jpds@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/restorecond')
-rw-r--r--sys-apps/restorecond/Manifest1
-rw-r--r--sys-apps/restorecond/restorecond-3.3.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/sys-apps/restorecond/Manifest b/sys-apps/restorecond/Manifest
index 163a8d8856f5..72a26729f3bb 100644
--- a/sys-apps/restorecond/Manifest
+++ b/sys-apps/restorecond/Manifest
@@ -1,2 +1,3 @@
DIST restorecond-3.1.tar.gz 18939 BLAKE2B 3a3fcde057dad3ed05692d679ba27e0b24f191d92ed5114fa38cb5f846c4cc00d85bb09b5d4e560ed2b914444e0c2d1c407f6c03900610624d5626d05f2991bc SHA512 cdcf299f48b89a7c641ded9507b9b966bf648497394f8e988a9cb1ceb3224c86369706027f3416a4f9750836f7a8f4580a4b3df76673e03f897b383d7ed0e2c8
DIST restorecond-3.2.tar.gz 18965 BLAKE2B 6cbd32c7c33fcc9f3fff78cc1faaa354c7ee918bfde8e12dfa73ce99632a8bc1e00d2f3b7cdd9c72179dbb51af1847e8dadd41cdc3ca20e9fb45e61871325029 SHA512 b1437a5d4dffef3463a0f2994f07c98585e9cfbc354db2dc07483fd9b964b079090697a277d2f4fd6bcd8df62f7505962fdca22d700721f6ba71490ace0167a9
+DIST restorecond-3.3.tar.gz 18970 BLAKE2B 41c0eed734ab1e89cdfd40fdb0ceff47e1c4bb66354ff78d548a9747c661fbf7ed4b6b3daa1e39325de2a2ca087aca803f073f942f3ac89b71d873e27a1d6712 SHA512 ea2b97d22c1d68aa4ea31d8850f8c9632c0db0d4d666e323c648da896554c6a6fdf6dfa3c105a1df3f1ede9da8cce5ba4c1533b05520846fcb2d584935e5d7cb
diff --git a/sys-apps/restorecond/restorecond-3.3.ebuild b/sys-apps/restorecond/restorecond-3.3.ebuild
new file mode 100644
index 000000000000..f3e66897e8c1
--- /dev/null
+++ b/sys-apps/restorecond/restorecond-3.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit systemd toolchain-funcs
+
+IUSE=""
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+fi
+
+DESCRIPTION="Daemon to watch for creation and set default SELinux fcontexts"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="dev-libs/glib:2
+ >=sys-libs/libsepol-${PV}:=
+ >=sys-libs/libselinux-${PV}:="
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' "${S}"/Makefile || die "Failed to remove Werror"
+}
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ SYSTEMDSYSTEMUNITDIR="$(systemd_get_systemunitdir)" \
+ SYSTEMDUSERUNITDIR=$(systemd_get_userunitdir) \
+ emake DESTDIR="${D}" install
+
+ rm -rf "${D}/etc/rc.d" || die
+
+ newinitd "${FILESDIR}/restorecond.init" restorecond
+}