summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2023-01-16 12:16:14 +0100
committerSam James <sam@gentoo.org>2023-01-17 01:52:13 +0000
commit01e67a01bd9d9e44f3351feca76f262bc9fa2685 (patch)
tree913d8d1a73c7cb25c6edf389fd6c80465746b13f /sys-apps/s6
parentsys-apps/s6: limit dependency due to an API change (diff)
downloadgentoo-01e67a01bd9d9e44f3351feca76f262bc9fa2685.tar.gz
gentoo-01e67a01bd9d9e44f3351feca76f262bc9fa2685.tar.bz2
gentoo-01e67a01bd9d9e44f3351feca76f262bc9fa2685.zip
sys-apps/s6: add 2.11.2.0
The --disable-static needs to be explicitly specified in configuration phase otherwise static libraries are created. Fixes: 01de0621eb30 ("sys-apps/s6: drop IUSE="static static-libs"") Bug: https://bugs.gentoo.org/890875 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/s6')
-rw-r--r--sys-apps/s6/Manifest1
-rw-r--r--sys-apps/s6/s6-2.11.2.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/sys-apps/s6/Manifest b/sys-apps/s6/Manifest
index 3877a13ec004..25935bf02a7e 100644
--- a/sys-apps/s6/Manifest
+++ b/sys-apps/s6/Manifest
@@ -1 +1,2 @@
DIST s6-2.11.1.2.tar.gz 229092 BLAKE2B 672321d1b9b1b66e7c920a9c587d2ad3a3ca66be7bac0e3f9b4d8290c9d716a3e90ccaac709dbe7ac6525b972ef95429c776805fce3e36fc5b197e9cc826d258 SHA512 31feb2b1704d9561aff9fccdcb284e13f4ceb0f530214db8a393bdc10267801fbe1fc30b4271ad9bdf189dc52e2844f3db40f8f3e9cd438ac12415a51661f17d
+DIST s6-2.11.2.0.tar.gz 246294 BLAKE2B c11fc25b9a209195a12cb12cb03560673c196c97cf5a0a66c850ed251dd387cdc1c6a002c9867ff9ad99faf1d8da42b4bb867074410d043c7cd2a8e8f1a2d44a SHA512 6666283d833f300d6d01984ffcc912e2ab49f88b756dc1748a2b997324c17494ad0e9dd40c0b0af8d367eaea99ab33be2d7afb070fa44e1991eb33776172e8a5
diff --git a/sys-apps/s6/s6-2.11.2.0.ebuild b/sys-apps/s6/s6-2.11.2.0.ebuild
new file mode 100644
index 000000000000..446c90bc9cc4
--- /dev/null
+++ b/sys-apps/s6/s6-2.11.2.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="skarnet.org's small and secure supervision software suite"
+HOMEPAGE="https://www.skarnet.org/software/s6/"
+SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+execline"
+
+RDEPEND=">=dev-libs/skalibs-2.13.0.0:=
+ execline? ( dev-lang/execline:= )
+"
+DEPEND="${RDEPEND}"
+
+HTML_DOCS=( doc/. )
+
+src_prepare() {
+ default
+
+ # Avoid QA warning for LDFLAGS addition
+ sed -i -e 's/.*-Wl,--hash-style=both$/:/' configure || die
+
+ sed -i -e '/AR := /d' -e '/RANLIB := /d' Makefile || die
+}
+
+src_configure() {
+ tc-export AR CC RANLIB
+
+ local myconf=(
+ --bindir=/bin
+ --dynlibdir=/usr/$(get_libdir)
+ --libdir=/usr/$(get_libdir)/${PN}
+ --with-dynlib=/usr/$(get_libdir)
+ --with-lib=/usr/$(get_libdir)/execline
+ --with-lib=/usr/$(get_libdir)/skalibs
+ --with-sysdeps=/usr/$(get_libdir)/skalibs
+ --enable-shared
+ --disable-allstatic
+ --disable-static
+ --disable-static-libc
+ $(use_enable execline)
+ )
+
+ econf "${myconf[@]}"
+}