summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/superiotool
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/superiotool')
-rw-r--r--sys-apps/superiotool/Manifest1
-rwxr-xr-xsys-apps/superiotool/files/make-tarball.sh34
-rw-r--r--sys-apps/superiotool/metadata.xml14
-rw-r--r--sys-apps/superiotool/superiotool-6637.ebuild48
-rw-r--r--sys-apps/superiotool/superiotool-99999999.ebuild48
5 files changed, 145 insertions, 0 deletions
diff --git a/sys-apps/superiotool/Manifest b/sys-apps/superiotool/Manifest
new file mode 100644
index 000000000000..e6ec40d8a1cc
--- /dev/null
+++ b/sys-apps/superiotool/Manifest
@@ -0,0 +1 @@
+DIST superiotool-6637.tar.xz 27364 RMD160 6a54fe45717a15bc3751455c310a16e3fa34ee9e SHA1 4e0c5c4c9778edd86443dcaf84cc102da351410c SHA256 e21e091c7679c2eeac66aa49499c02587d64a41b3b36449f4ec06dafc8f0ba21
diff --git a/sys-apps/superiotool/files/make-tarball.sh b/sys-apps/superiotool/files/make-tarball.sh
new file mode 100755
index 000000000000..3711db140db3
--- /dev/null
+++ b/sys-apps/superiotool/files/make-tarball.sh
@@ -0,0 +1,34 @@
+#!/bin/bash
+
+. /etc/init.d/functions.sh
+
+svnrev() { svn info "$1" | awk '$1 == "Revision:" { print $NF }'; }
+
+PN=superiotool
+SVN_ROOT=${2:-/usr/local/src}
+srcdir=${SVN_ROOT}/${PN}
+PV=${1:-$(svnrev "${srcdir}")}
+
+P=${PN}-${PV}
+T=/tmp
+
+if [[ -d ${srcdir} ]] ; then
+ cd "${T}" || die
+
+ rm -rf ${P}
+
+ ebegin "Exporting ${srcdir} ${PV} to ${P}"
+ svn export -q -r ${PV} ${srcdir} ${P}
+ eend $? || die
+
+ ebegin "Creating ${P}.tar.xz"
+ tar cf - ${P} | xz > ${P}.tar.xz
+ eend $?
+
+ einfo "Tarball now ready at: ${T}/${P}.tar.xz"
+else
+ einfo "You need to run:"
+ einfo " cd ${base}"
+ einfo " svn co svn://coreboot.org/coreboot/trunk/util/superiotool"
+ die "need svn checkout dir"
+fi
diff --git a/sys-apps/superiotool/metadata.xml b/sys-apps/superiotool/metadata.xml
new file mode 100644
index 000000000000..8c509c1d6234
--- /dev/null
+++ b/sys-apps/superiotool/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>idl0r@gentoo.org</email>
+ <name>Christian Ruppert</name>
+ </maintainer>
+ <maintainer>
+ <email>vapier@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="pci">Support for PCI-attached "Super I/Os" (e.g. in VIA VT82686A/B).</flag>
+ </use>
+</pkgmetadata>
diff --git a/sys-apps/superiotool/superiotool-6637.ebuild b/sys-apps/superiotool/superiotool-6637.ebuild
new file mode 100644
index 000000000000..b5c936ac721b
--- /dev/null
+++ b/sys-apps/superiotool/superiotool-6637.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs eutils
+
+if [[ ${PV} == "99999999" ]] ; then
+ ESVN_REPO_URI="svn://coreboot.org/coreboot/trunk/util/${PN}"
+ inherit subversion
+ SRC_URI=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="util to detect Super I/O chips and functionality"
+HOMEPAGE="http://www.coreboot.org/Superiotool"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="pci"
+
+RDEPEND="pci? ( sys-apps/pciutils )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils"
+
+src_prepare() {
+ sed -i \
+ -e 's:-Werror ::' \
+ -e 's:-O2 ::' \
+ -e 's:\s\+\?-lz\s\+\?::' \
+ -e "/^CONFIG_PCI =/s:=.*:=$(usex pci yes no):" \
+ -e '/PREFIX/s:=.*:= /usr:' \
+ Makefile || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ SVNDEF="-D'SUPERIOTOOL_VERSION=\"${ESVN_WC_REVISION}\"'"
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc README
+}
diff --git a/sys-apps/superiotool/superiotool-99999999.ebuild b/sys-apps/superiotool/superiotool-99999999.ebuild
new file mode 100644
index 000000000000..b5c936ac721b
--- /dev/null
+++ b/sys-apps/superiotool/superiotool-99999999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs eutils
+
+if [[ ${PV} == "99999999" ]] ; then
+ ESVN_REPO_URI="svn://coreboot.org/coreboot/trunk/util/${PN}"
+ inherit subversion
+ SRC_URI=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="util to detect Super I/O chips and functionality"
+HOMEPAGE="http://www.coreboot.org/Superiotool"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="pci"
+
+RDEPEND="pci? ( sys-apps/pciutils )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils"
+
+src_prepare() {
+ sed -i \
+ -e 's:-Werror ::' \
+ -e 's:-O2 ::' \
+ -e 's:\s\+\?-lz\s\+\?::' \
+ -e "/^CONFIG_PCI =/s:=.*:=$(usex pci yes no):" \
+ -e '/PREFIX/s:=.*:= /usr:' \
+ Makefile || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ SVNDEF="-D'SUPERIOTOOL_VERSION=\"${ESVN_WC_REVISION}\"'"
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc README
+}