summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /sys-apps
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/coreutils/coreutils-8.30.ebuild1
-rw-r--r--sys-apps/coreutils/coreutils-8.31-r1.ebuild1
-rw-r--r--sys-apps/coreutils/coreutils-8.31.ebuild1
-rw-r--r--sys-apps/dbus/dbus-1.12.16.ebuild1
-rw-r--r--sys-apps/ethq/ethq-0.5.0.ebuild3
-rw-r--r--sys-apps/ethq/ethq-0.6.1.ebuild3
-rw-r--r--sys-apps/ethq/ethq-9999.ebuild3
-rw-r--r--sys-apps/fakeroot/fakeroot-1.22.ebuild3
-rw-r--r--sys-apps/fakeroot/fakeroot-1.23.ebuild3
-rw-r--r--sys-apps/fakeroot/fakeroot-1.24.ebuild1
-rw-r--r--sys-apps/findutils/findutils-4.6.0-r1.ebuild1
-rw-r--r--sys-apps/findutils/findutils-4.7.0.ebuild1
-rw-r--r--sys-apps/firejail-lts/firejail-lts-0.9.56.2-r1.ebuild1
-rw-r--r--sys-apps/firejail-lts/firejail-lts-0.9.56.2.ebuild1
-rw-r--r--sys-apps/fwupd/fwupd-1.2.11.ebuild1
-rw-r--r--sys-apps/fwupd/fwupd-1.2.8.ebuild1
-rw-r--r--sys-apps/gsmartcontrol/gsmartcontrol-1.0.2.ebuild3
-rw-r--r--sys-apps/gsmartcontrol/gsmartcontrol-1.1.3.ebuild3
-rw-r--r--sys-apps/kbd/kbd-2.0.4-r1.ebuild1
-rw-r--r--sys-apps/kbd/kbd-2.0.4.ebuild1
-rw-r--r--sys-apps/kbd/kbd-2.2.0-r2.ebuild1
-rw-r--r--sys-apps/kbd/kbd-9999.ebuild1
-rw-r--r--sys-apps/keyutils/keyutils-1.6.1.ebuild1
-rw-r--r--sys-apps/lmctfy/lmctfy-0.2.0.ebuild3
-rw-r--r--sys-apps/lmctfy/lmctfy-0.3.0.ebuild3
-rw-r--r--sys-apps/lmctfy/lmctfy-0.3.1.ebuild3
-rw-r--r--sys-apps/lmctfy/lmctfy-0.5.0-r1.ebuild3
-rw-r--r--sys-apps/lmctfy/lmctfy-0.5.0.ebuild3
-rw-r--r--sys-apps/miller/miller-5.3.0.ebuild1
-rw-r--r--sys-apps/minijail/minijail-9.ebuild1
-rw-r--r--sys-apps/sydbox/sydbox-1.0.7.ebuild3
-rw-r--r--sys-apps/the_silver_searcher/the_silver_searcher-2.0.0.ebuild3
-rw-r--r--sys-apps/the_silver_searcher/the_silver_searcher-2.1.0.ebuild3
33 files changed, 48 insertions, 15 deletions
diff --git a/sys-apps/coreutils/coreutils-8.30.ebuild b/sys-apps/coreutils/coreutils-8.30.ebuild
index cffb6d4a9a00..9ae4f449d03d 100644
--- a/sys-apps/coreutils/coreutils-8.30.ebuild
+++ b/sys-apps/coreutils/coreutils-8.30.ebuild
@@ -18,6 +18,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-linux"
IUSE="acl caps gmp hostname kill multicall nls selinux +split-usr static test userland_BSD vanilla xattr"
+RESTRICT="!test? ( test )"
LIB_DEPEND="acl? ( sys-apps/acl[static-libs] )
caps? ( sys-libs/libcap )
diff --git a/sys-apps/coreutils/coreutils-8.31-r1.ebuild b/sys-apps/coreutils/coreutils-8.31-r1.ebuild
index 4b4527d15146..2d9f4afdf1ea 100644
--- a/sys-apps/coreutils/coreutils-8.31-r1.ebuild
+++ b/sys-apps/coreutils/coreutils-8.31-r1.ebuild
@@ -18,6 +18,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~x86-linux"
IUSE="acl caps gmp hostname kill multicall nls selinux +split-usr static test vanilla xattr"
+RESTRICT="!test? ( test )"
LIB_DEPEND="acl? ( sys-apps/acl[static-libs] )
caps? ( sys-libs/libcap )
diff --git a/sys-apps/coreutils/coreutils-8.31.ebuild b/sys-apps/coreutils/coreutils-8.31.ebuild
index 4748ab387195..11bcf3e5b620 100644
--- a/sys-apps/coreutils/coreutils-8.31.ebuild
+++ b/sys-apps/coreutils/coreutils-8.31.ebuild
@@ -18,6 +18,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~x86-linux"
IUSE="acl caps gmp hostname kill multicall nls selinux +split-usr static test userland_BSD vanilla xattr"
+RESTRICT="!test? ( test )"
LIB_DEPEND="acl? ( sys-apps/acl[static-libs] )
caps? ( sys-libs/libcap )
diff --git a/sys-apps/dbus/dbus-1.12.16.ebuild b/sys-apps/dbus/dbus-1.12.16.ebuild
index fd7c0d7139d4..f4be11b25cea 100644
--- a/sys-apps/dbus/dbus-1.12.16.ebuild
+++ b/sys-apps/dbus/dbus-1.12.16.ebuild
@@ -14,6 +14,7 @@ LICENSE="|| ( AFL-2.1 GPL-2 )"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="debug doc elogind kernel_linux selinux static-libs systemd test user-session X"
+RESTRICT="!test? ( test )"
REQUIRED_USE="?? ( elogind systemd )"
diff --git a/sys-apps/ethq/ethq-0.5.0.ebuild b/sys-apps/ethq/ethq-0.5.0.ebuild
index eaaf909be1af..937e95dba856 100644
--- a/sys-apps/ethq/ethq-0.5.0.ebuild
+++ b/sys-apps/ethq/ethq-0.5.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,6 +16,7 @@ LICENSE="MPL-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
DEPEND="sys-libs/ncurses:0"
RDEPEND="${DEPEND}"
diff --git a/sys-apps/ethq/ethq-0.6.1.ebuild b/sys-apps/ethq/ethq-0.6.1.ebuild
index 71eae77cf755..b5718cb8f726 100644
--- a/sys-apps/ethq/ethq-0.6.1.ebuild
+++ b/sys-apps/ethq/ethq-0.6.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,6 +16,7 @@ LICENSE="MPL-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
DEPEND="sys-libs/ncurses:0"
RDEPEND="${DEPEND}"
diff --git a/sys-apps/ethq/ethq-9999.ebuild b/sys-apps/ethq/ethq-9999.ebuild
index a64bcead00ae..59fa6fa3cdc7 100644
--- a/sys-apps/ethq/ethq-9999.ebuild
+++ b/sys-apps/ethq/ethq-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -15,6 +15,7 @@ LICENSE="MPL-2.0"
SLOT="0"
KEYWORDS=""
IUSE="test"
+RESTRICT="!test? ( test )"
DEPEND="sys-libs/ncurses:0"
RDEPEND="${DEPEND}"
diff --git a/sys-apps/fakeroot/fakeroot-1.22.ebuild b/sys-apps/fakeroot/fakeroot-1.22.ebuild
index 4ca2e7a5a9eb..2188878e4d84 100644
--- a/sys-apps/fakeroot/fakeroot-1.22.ebuild
+++ b/sys-apps/fakeroot/fakeroot-1.22.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -13,6 +13,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
IUSE="acl debug static-libs test"
+RESTRICT="!test? ( test )"
DEPEND="
sys-libs/libcap
diff --git a/sys-apps/fakeroot/fakeroot-1.23.ebuild b/sys-apps/fakeroot/fakeroot-1.23.ebuild
index 91ad0aff45d0..c0f5629f8051 100644
--- a/sys-apps/fakeroot/fakeroot-1.23.ebuild
+++ b/sys-apps/fakeroot/fakeroot-1.23.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -13,6 +13,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="acl debug static-libs test"
+RESTRICT="!test? ( test )"
DEPEND="
sys-libs/libcap
diff --git a/sys-apps/fakeroot/fakeroot-1.24.ebuild b/sys-apps/fakeroot/fakeroot-1.24.ebuild
index 336e7ca459d8..791263fdb16c 100644
--- a/sys-apps/fakeroot/fakeroot-1.24.ebuild
+++ b/sys-apps/fakeroot/fakeroot-1.24.ebuild
@@ -13,6 +13,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="acl debug static-libs test"
+RESTRICT="!test? ( test )"
DEPEND="
sys-libs/libcap
diff --git a/sys-apps/findutils/findutils-4.6.0-r1.ebuild b/sys-apps/findutils/findutils-4.6.0-r1.ebuild
index b6d13252c1e9..b6d494b7d91d 100644
--- a/sys-apps/findutils/findutils-4.6.0-r1.ebuild
+++ b/sys-apps/findutils/findutils-4.6.0-r1.ebuild
@@ -15,6 +15,7 @@ LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="nls selinux static test"
+RESTRICT="!test? ( test )"
RDEPEND="selinux? ( sys-libs/libselinux )
nls? ( virtual/libintl )"
diff --git a/sys-apps/findutils/findutils-4.7.0.ebuild b/sys-apps/findutils/findutils-4.7.0.ebuild
index 10d528fd7b91..e42dba38fb07 100644
--- a/sys-apps/findutils/findutils-4.7.0.ebuild
+++ b/sys-apps/findutils/findutils-4.7.0.ebuild
@@ -15,6 +15,7 @@ LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="nls selinux static test"
+RESTRICT="!test? ( test )"
RDEPEND="selinux? ( sys-libs/libselinux )
nls? ( virtual/libintl )"
diff --git a/sys-apps/firejail-lts/firejail-lts-0.9.56.2-r1.ebuild b/sys-apps/firejail-lts/firejail-lts-0.9.56.2-r1.ebuild
index 831a680daa5e..0cd44b693c7e 100644
--- a/sys-apps/firejail-lts/firejail-lts-0.9.56.2-r1.ebuild
+++ b/sys-apps/firejail-lts/firejail-lts-0.9.56.2-r1.ebuild
@@ -14,6 +14,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
IUSE="apparmor +globalcfg +network +seccomp +suid +userns test +whitelist"
+RESTRICT="!test? ( test )"
DEPEND="!sys-apps/firejail
apparmor? ( sys-libs/libapparmor )
diff --git a/sys-apps/firejail-lts/firejail-lts-0.9.56.2.ebuild b/sys-apps/firejail-lts/firejail-lts-0.9.56.2.ebuild
index 58dc1df4e153..7ded7fe5cedd 100644
--- a/sys-apps/firejail-lts/firejail-lts-0.9.56.2.ebuild
+++ b/sys-apps/firejail-lts/firejail-lts-0.9.56.2.ebuild
@@ -14,6 +14,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
IUSE="apparmor +globalcfg +network +seccomp +suid +userns test +whitelist"
+RESTRICT="!test? ( test )"
DEPEND="!sys-apps/firejail
apparmor? ( sys-libs/libapparmor )
diff --git a/sys-apps/fwupd/fwupd-1.2.11.ebuild b/sys-apps/fwupd/fwupd-1.2.11.ebuild
index 0fb2bd8ef285..890023716a05 100644
--- a/sys-apps/fwupd/fwupd-1.2.11.ebuild
+++ b/sys-apps/fwupd/fwupd-1.2.11.ebuild
@@ -15,6 +15,7 @@ LICENSE="LGPL-2.1+"
SLOT="0"
KEYWORDS="amd64 ~arm ~x86"
IUSE="agent colorhug consolekit dell doc elogind +gpg +man nvme pkcs7 redfish systemd test thunderbolt uefi"
+RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
^^ ( consolekit elogind systemd )
diff --git a/sys-apps/fwupd/fwupd-1.2.8.ebuild b/sys-apps/fwupd/fwupd-1.2.8.ebuild
index 9107999ee4a7..a1aaa0b451dd 100644
--- a/sys-apps/fwupd/fwupd-1.2.8.ebuild
+++ b/sys-apps/fwupd/fwupd-1.2.8.ebuild
@@ -15,6 +15,7 @@ LICENSE="LGPL-2.1+"
SLOT="0"
KEYWORDS="amd64 ~arm x86"
IUSE="agent colorhug consolekit dell doc elogind +gpg +man nvme pkcs7 redfish systemd test thunderbolt uefi"
+RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
^^ ( consolekit elogind systemd )
diff --git a/sys-apps/gsmartcontrol/gsmartcontrol-1.0.2.ebuild b/sys-apps/gsmartcontrol/gsmartcontrol-1.0.2.ebuild
index 06f8b94bf918..66da4d4c59b9 100644
--- a/sys-apps/gsmartcontrol/gsmartcontrol-1.0.2.ebuild
+++ b/sys-apps/gsmartcontrol/gsmartcontrol-1.0.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,6 +12,7 @@ LICENSE="|| ( GPL-2 GPL-3 ) Boost-1.0 BSD Unlicense ZLIB"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="test"
+RESTRICT="!test? ( test )"
COMMON_DEPEND="
dev-cpp/gtkmm:3.0
diff --git a/sys-apps/gsmartcontrol/gsmartcontrol-1.1.3.ebuild b/sys-apps/gsmartcontrol/gsmartcontrol-1.1.3.ebuild
index b5b1c6d82126..66da4d4c59b9 100644
--- a/sys-apps/gsmartcontrol/gsmartcontrol-1.1.3.ebuild
+++ b/sys-apps/gsmartcontrol/gsmartcontrol-1.1.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,6 +12,7 @@ LICENSE="|| ( GPL-2 GPL-3 ) Boost-1.0 BSD Unlicense ZLIB"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="test"
+RESTRICT="!test? ( test )"
COMMON_DEPEND="
dev-cpp/gtkmm:3.0
diff --git a/sys-apps/kbd/kbd-2.0.4-r1.ebuild b/sys-apps/kbd/kbd-2.0.4-r1.ebuild
index 3be269cae6ce..58d6b6dfff53 100644
--- a/sys-apps/kbd/kbd-2.0.4-r1.ebuild
+++ b/sys-apps/kbd/kbd-2.0.4-r1.ebuild
@@ -20,6 +20,7 @@ HOMEPAGE="http://kbd-project.org/"
LICENSE="GPL-2"
SLOT="0"
IUSE="nls pam test"
+RESTRICT="!test? ( test )"
RDEPEND="
app-arch/gzip
diff --git a/sys-apps/kbd/kbd-2.0.4.ebuild b/sys-apps/kbd/kbd-2.0.4.ebuild
index 87cfa64484eb..9dde0feca4ed 100644
--- a/sys-apps/kbd/kbd-2.0.4.ebuild
+++ b/sys-apps/kbd/kbd-2.0.4.ebuild
@@ -21,6 +21,7 @@ HOMEPAGE="http://kbd-project.org/"
LICENSE="GPL-2"
SLOT="0"
IUSE="nls pam test"
+RESTRICT="!test? ( test )"
RDEPEND="pam? ( sys-libs/pam )
app-arch/gzip"
diff --git a/sys-apps/kbd/kbd-2.2.0-r2.ebuild b/sys-apps/kbd/kbd-2.2.0-r2.ebuild
index da63a90d2cef..19c32fde0fff 100644
--- a/sys-apps/kbd/kbd-2.2.0-r2.ebuild
+++ b/sys-apps/kbd/kbd-2.2.0-r2.ebuild
@@ -21,6 +21,7 @@ HOMEPAGE="http://kbd-project.org/"
LICENSE="GPL-2"
SLOT="0"
IUSE="nls pam test"
+RESTRICT="!test? ( test )"
RDEPEND="
app-arch/gzip
diff --git a/sys-apps/kbd/kbd-9999.ebuild b/sys-apps/kbd/kbd-9999.ebuild
index 06fb77295c43..85d244167140 100644
--- a/sys-apps/kbd/kbd-9999.ebuild
+++ b/sys-apps/kbd/kbd-9999.ebuild
@@ -21,6 +21,7 @@ HOMEPAGE="http://kbd-project.org/"
LICENSE="GPL-2"
SLOT="0"
IUSE="nls pam test"
+RESTRICT="!test? ( test )"
RDEPEND="
app-arch/gzip
diff --git a/sys-apps/keyutils/keyutils-1.6.1.ebuild b/sys-apps/keyutils/keyutils-1.6.1.ebuild
index d6bea1f56a1a..b69a471cf390 100644
--- a/sys-apps/keyutils/keyutils-1.6.1.ebuild
+++ b/sys-apps/keyutils/keyutils-1.6.1.ebuild
@@ -13,6 +13,7 @@ LICENSE="GPL-2 LGPL-2.1"
SLOT="0/1.9"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
IUSE="static static-libs test"
+RESTRICT="!test? ( test )"
RDEPEND=""
DEPEND="!prefix? ( >=sys-kernel/linux-headers-2.6.11 )"
diff --git a/sys-apps/lmctfy/lmctfy-0.2.0.ebuild b/sys-apps/lmctfy/lmctfy-0.2.0.ebuild
index 7dc9a7fa21f8..42165974ce90 100644
--- a/sys-apps/lmctfy/lmctfy-0.2.0.ebuild
+++ b/sys-apps/lmctfy/lmctfy-0.2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -13,6 +13,7 @@ SLOT="0"
LICENSE="Apache-2.0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
DEPEND="
dev-libs/protobuf
diff --git a/sys-apps/lmctfy/lmctfy-0.3.0.ebuild b/sys-apps/lmctfy/lmctfy-0.3.0.ebuild
index 34bfaef96ae1..42165974ce90 100644
--- a/sys-apps/lmctfy/lmctfy-0.3.0.ebuild
+++ b/sys-apps/lmctfy/lmctfy-0.3.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -13,6 +13,7 @@ SLOT="0"
LICENSE="Apache-2.0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
DEPEND="
dev-libs/protobuf
diff --git a/sys-apps/lmctfy/lmctfy-0.3.1.ebuild b/sys-apps/lmctfy/lmctfy-0.3.1.ebuild
index 34bfaef96ae1..42165974ce90 100644
--- a/sys-apps/lmctfy/lmctfy-0.3.1.ebuild
+++ b/sys-apps/lmctfy/lmctfy-0.3.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -13,6 +13,7 @@ SLOT="0"
LICENSE="Apache-2.0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
DEPEND="
dev-libs/protobuf
diff --git a/sys-apps/lmctfy/lmctfy-0.5.0-r1.ebuild b/sys-apps/lmctfy/lmctfy-0.5.0-r1.ebuild
index 76093fd584cc..b55a5841ffc9 100644
--- a/sys-apps/lmctfy/lmctfy-0.5.0-r1.ebuild
+++ b/sys-apps/lmctfy/lmctfy-0.5.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -13,6 +13,7 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
COMMON_DEPEND="
dev-libs/protobuf
diff --git a/sys-apps/lmctfy/lmctfy-0.5.0.ebuild b/sys-apps/lmctfy/lmctfy-0.5.0.ebuild
index 525a157e1df6..26f7f25c22ba 100644
--- a/sys-apps/lmctfy/lmctfy-0.5.0.ebuild
+++ b/sys-apps/lmctfy/lmctfy-0.5.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -13,6 +13,7 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
DEPEND="
dev-libs/protobuf
diff --git a/sys-apps/miller/miller-5.3.0.ebuild b/sys-apps/miller/miller-5.3.0.ebuild
index 863789ce5ce6..1412928d0805 100644
--- a/sys-apps/miller/miller-5.3.0.ebuild
+++ b/sys-apps/miller/miller-5.3.0.ebuild
@@ -13,6 +13,7 @@ LICENSE="BSD-2"
SLOT="0"
KEYWORDS="amd64 arm x86"
IUSE="doc test"
+RESTRICT="!test? ( test )"
DEPEND="sys-devel/flex"
diff --git a/sys-apps/minijail/minijail-9.ebuild b/sys-apps/minijail/minijail-9.ebuild
index 3daec8d2d3b5..a11b63da62ab 100644
--- a/sys-apps/minijail/minijail-9.ebuild
+++ b/sys-apps/minijail/minijail-9.ebuild
@@ -15,6 +15,7 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+seccomp test"
+RESTRICT="!test? ( test )"
RDEPEND="sys-libs/libcap-ng:="
DEPEND="${RDEPEND}
diff --git a/sys-apps/sydbox/sydbox-1.0.7.ebuild b/sys-apps/sydbox/sydbox-1.0.7.ebuild
index 951a50fa3a49..20a823ec7181 100644
--- a/sys-apps/sydbox/sydbox-1.0.7.ebuild
+++ b/sys-apps/sydbox/sydbox-1.0.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -11,6 +11,7 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
IUSE="debug seccomp test"
+RESTRICT="!test? ( test )"
RDEPEND="sys-libs/pinktrace:=
debug? ( sys-libs/libunwind:= )"
diff --git a/sys-apps/the_silver_searcher/the_silver_searcher-2.0.0.ebuild b/sys-apps/the_silver_searcher/the_silver_searcher-2.0.0.ebuild
index dbb2622af385..21b02d12de35 100644
--- a/sys-apps/the_silver_searcher/the_silver_searcher-2.0.0.ebuild
+++ b/sys-apps/the_silver_searcher/the_silver_searcher-2.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,6 +12,7 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm ~hppa ~mips ~ppc ~ppc64 x86"
IUSE="lzma test zlib"
+RESTRICT="!test? ( test )"
RDEPEND="dev-libs/libpcre
lzma? ( app-arch/xz-utils )
diff --git a/sys-apps/the_silver_searcher/the_silver_searcher-2.1.0.ebuild b/sys-apps/the_silver_searcher/the_silver_searcher-2.1.0.ebuild
index fcf0eba32492..f8bf1e852265 100644
--- a/sys-apps/the_silver_searcher/the_silver_searcher-2.1.0.ebuild
+++ b/sys-apps/the_silver_searcher/the_silver_searcher-2.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,6 +12,7 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~x86 ~amd64-linux"
IUSE="lzma test zlib"
+RESTRICT="!test? ( test )"
RDEPEND="dev-libs/libpcre
lzma? ( app-arch/xz-utils )