summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2025-02-04 14:21:09 -0500
committerMike Gilbert <floppym@gentoo.org>2025-02-04 14:21:09 -0500
commit3846fd977b690e08f8e270136319e6556289e844 (patch)
tree550ef331a9bf94a09977b6b27931055be31b1c07 /sys-apps
parentmedia-radio/wsjtx: add 2.7.0_rc8 (diff)
downloadgentoo-3846fd977b690e08f8e270136319e6556289e844.tar.gz
gentoo-3846fd977b690e08f8e270136319e6556289e844.tar.bz2
gentoo-3846fd977b690e08f8e270136319e6556289e844.zip
sys-apps/coreutils: do not xfail tests when sandbox is disabled
Closes: https://bugs.gentoo.org/949092 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/coreutils/coreutils-9.6.ebuild50
-rw-r--r--sys-apps/coreutils/coreutils-9999.ebuild50
2 files changed, 54 insertions, 46 deletions
diff --git a/sys-apps/coreutils/coreutils-9.6.ebuild b/sys-apps/coreutils/coreutils-9.6.ebuild
index 6630d91c84d5..13548680185c 100644
--- a/sys-apps/coreutils/coreutils-9.6.ebuild
+++ b/sys-apps/coreutils/coreutils-9.6.ebuild
@@ -221,29 +221,33 @@ src_test() {
local -x PATH="${T}/mount-wrappers:${PATH}"
local -x gl_public_submodule_commit=
- local xfail_tests=(
- # bug #629660
- # Commented out again in 9.6 as it XPASSes on linux-6.12.10
- # with sandbox-2.43 on tmpfs. Let's see if it lasts..
- #tests/dd/no-allocate.sh
-
- # bug #675802
- tests/env/env-S
- tests/env/env-S.pl
-
- # bug #413621 and bug #548250
- tests/du/long-from-unreadable.sh
- tests/ls/removed-directory
- tests/ls/removed-directory.sh
- tests/ls/stat-free-symlinks
- tests/ls/stat-free-symlinks.sh
- tests/rm/deep-2
- tests/rm/deep-2.sh
-
- # We have a patch which fixes this (bug #259876)
- #tests/touch/not-owner
- #tests/touch/not-owner.sh
- )
+ local xfail_tests=()
+
+ if [[ -n ${SANDBOX_ACTIVE} ]]; then
+ xfail_tests+=(
+ # bug #629660
+ # Commented out again in 9.6 as it XPASSes on linux-6.12.10
+ # with sandbox-2.43 on tmpfs. Let's see if it lasts..
+ #tests/dd/no-allocate.sh
+
+ # bug #675802
+ tests/env/env-S
+ tests/env/env-S.pl
+
+ # bug #413621 and bug #548250
+ tests/du/long-from-unreadable.sh
+ tests/ls/removed-directory
+ tests/ls/removed-directory.sh
+ tests/ls/stat-free-symlinks
+ tests/ls/stat-free-symlinks.sh
+ tests/rm/deep-2
+ tests/rm/deep-2.sh
+
+ # We have a patch which fixes this (bug #259876)
+ #tests/touch/not-owner
+ #tests/touch/not-owner.sh
+ )
+ fi
# This test is flaky (bug #910640).
cat > tests/tty/tty-eof.pl <<-EOF || die
diff --git a/sys-apps/coreutils/coreutils-9999.ebuild b/sys-apps/coreutils/coreutils-9999.ebuild
index 6630d91c84d5..13548680185c 100644
--- a/sys-apps/coreutils/coreutils-9999.ebuild
+++ b/sys-apps/coreutils/coreutils-9999.ebuild
@@ -221,29 +221,33 @@ src_test() {
local -x PATH="${T}/mount-wrappers:${PATH}"
local -x gl_public_submodule_commit=
- local xfail_tests=(
- # bug #629660
- # Commented out again in 9.6 as it XPASSes on linux-6.12.10
- # with sandbox-2.43 on tmpfs. Let's see if it lasts..
- #tests/dd/no-allocate.sh
-
- # bug #675802
- tests/env/env-S
- tests/env/env-S.pl
-
- # bug #413621 and bug #548250
- tests/du/long-from-unreadable.sh
- tests/ls/removed-directory
- tests/ls/removed-directory.sh
- tests/ls/stat-free-symlinks
- tests/ls/stat-free-symlinks.sh
- tests/rm/deep-2
- tests/rm/deep-2.sh
-
- # We have a patch which fixes this (bug #259876)
- #tests/touch/not-owner
- #tests/touch/not-owner.sh
- )
+ local xfail_tests=()
+
+ if [[ -n ${SANDBOX_ACTIVE} ]]; then
+ xfail_tests+=(
+ # bug #629660
+ # Commented out again in 9.6 as it XPASSes on linux-6.12.10
+ # with sandbox-2.43 on tmpfs. Let's see if it lasts..
+ #tests/dd/no-allocate.sh
+
+ # bug #675802
+ tests/env/env-S
+ tests/env/env-S.pl
+
+ # bug #413621 and bug #548250
+ tests/du/long-from-unreadable.sh
+ tests/ls/removed-directory
+ tests/ls/removed-directory.sh
+ tests/ls/stat-free-symlinks
+ tests/ls/stat-free-symlinks.sh
+ tests/rm/deep-2
+ tests/rm/deep-2.sh
+
+ # We have a patch which fixes this (bug #259876)
+ #tests/touch/not-owner
+ #tests/touch/not-owner.sh
+ )
+ fi
# This test is flaky (bug #910640).
cat > tests/tty/tty-eof.pl <<-EOF || die