summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-03-19 18:32:04 -0300
committerMatt Turner <mattst88@gentoo.org>2023-03-19 19:38:20 -0400
commit5b55272cd4191a05b9786784483a143a93327a11 (patch)
tree3349a3049e65b565101f3d1e5119ba6edf99b12e /sys-apps
parentapp-misc/gnote: Version bump to 44.0 (diff)
downloadgentoo-5b55272cd4191a05b9786784483a143a93327a11.tar.gz
gentoo-5b55272cd4191a05b9786784483a143a93327a11.tar.bz2
gentoo-5b55272cd4191a05b9786784483a143a93327a11.zip
sys-apps/xdg-desktop-portal-gnome: Version bump to 44.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/30250 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/xdg-desktop-portal-gnome/Manifest1
-rw-r--r--sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-44.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal-gnome/Manifest b/sys-apps/xdg-desktop-portal-gnome/Manifest
index e1a2d817b1de..44880863c2ce 100644
--- a/sys-apps/xdg-desktop-portal-gnome/Manifest
+++ b/sys-apps/xdg-desktop-portal-gnome/Manifest
@@ -1,2 +1,3 @@
DIST xdg-desktop-portal-gnome-43.1.tar.xz 125248 BLAKE2B 5290041b3b0d24c6d62c1433c492fa5b04af80493d192392d6b89839356c1a4f2c74aba5509476bd5df5383375889d50636216b52e2448de1b3c8360501cb16b SHA512 fc9b2a0bf5483194326308099be0cb76245644bfc26546a4e63679eb695400cf254aa9e85de1b168e07ba7f05eb4f9fe4fde31853bcee4bd8bfb94063933ebc3
+DIST xdg-desktop-portal-gnome-44.0.tar.xz 127076 BLAKE2B e8775fe8017b5112bba995cea830a64b5f77222e40f09bf5318bed720274a7516cd2178b6d132b71b9608aae2885b9f9cab679a5abce25cd099591633a8a51e7 SHA512 1aa8eae420f4bf00ea34b3ad665edad89f9444bd2d5baa84d1f96b303ab072c66c139eb760cfbfd796691bda745f3eb5455f8d805fb042c8037eb786a730eb95
DIST xdg-desktop-portal-gnome-44.rc.tar.xz 127040 BLAKE2B b762d1e29cad9ed9afa98cfd98793a2b27c1553beccdaf6bccceaf642cd35d9d28bcbc3b4be891d1fb54efe99a27d62cf190f317deb26ea837b73b0448272a58 SHA512 bb3be21cbb4cb0e1fb22ae70d4c47cbd8b8bc6e87d4495f967fb4f8494cdcb0f1b3d03c15d12ed9cec4fca31151e99a967b38b3eb46cfdcc791f399185ceeacc
diff --git a/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-44.0.ebuild b/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-44.0.ebuild
new file mode 100644
index 000000000000..ef62dd2dfcc4
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-44.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson systemd xdg
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal using GNOME"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/xdg-desktop-portal-gnome"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="wayland X"
+
+DEPEND="
+ dev-libs/glib:2
+ gnome-base/gnome-desktop:4=
+ gui-libs/libadwaita:1
+ media-libs/fontconfig
+ sys-apps/dbus
+ >=sys-apps/xdg-desktop-portal-1.15.0
+ >=sys-apps/xdg-desktop-portal-gtk-1.14.0
+ gui-libs/gtk:4[wayland?,X?]
+ X? ( x11-libs/libX11 )
+ wayland? ( dev-libs/wayland )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ wayland? ( dev-util/wayland-scanner )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dsystemduserunitdir="$(systemd_get_userunitdir)"
+ )
+
+ meson_src_configure
+}