summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-auth/polkit-kde-agent
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-auth/polkit-kde-agent')
-rw-r--r--sys-auth/polkit-kde-agent/Manifest1
-rw-r--r--sys-auth/polkit-kde-agent/metadata.xml8
-rw-r--r--sys-auth/polkit-kde-agent/polkit-kde-agent-0.99.1-r1.ebuild44
3 files changed, 53 insertions, 0 deletions
diff --git a/sys-auth/polkit-kde-agent/Manifest b/sys-auth/polkit-kde-agent/Manifest
new file mode 100644
index 000000000000..0b4fe480a745
--- /dev/null
+++ b/sys-auth/polkit-kde-agent/Manifest
@@ -0,0 +1 @@
+DIST polkit-kde-1_0.99.1.orig.tar.xz 38060 SHA256 336fffb8b9b8c1490537dc557c6ea8d66499739f69d479150f1a2961a4be46ff SHA512 14beb0c3bb00a62fd601ea94da158946c91f443b14ff286d9475e1883e5f102afbda81d8f214417a957bd7ba449b7c41f596d1ac05d97e8ffc836e76bb680d4f WHIRLPOOL e83d6f1a95729e8838788ed21651498713b8d1513ae5878a89064c1af62bd4b6fa741711ec66f004b96547f60f150fa4ec4b6ca27d2265bc10c6fbaca955f57a
diff --git a/sys-auth/polkit-kde-agent/metadata.xml b/sys-auth/polkit-kde-agent/metadata.xml
new file mode 100644
index 000000000000..ab3442450edb
--- /dev/null
+++ b/sys-auth/polkit-kde-agent/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <upstream>
+ <remote-id type="launchpad">ubuntu</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-auth/polkit-kde-agent/polkit-kde-agent-0.99.1-r1.ebuild b/sys-auth/polkit-kde-agent/polkit-kde-agent-0.99.1-r1.ebuild
new file mode 100644
index 000000000000..6f05189e8baa
--- /dev/null
+++ b/sys-auth/polkit-kde-agent/polkit-kde-agent-0.99.1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN="${PN}-1"
+MY_P="${MY_PN}-${PV}"
+EGIT_REPONAME="${MY_PN}"
+KDE_LINGUAS="ar bs ca ca@valencia cs da de el en_GB eo es et fi fr
+ ga gl hr hu is it ja kk km lt mai mr ms nb nds nl pa pl pt pt_BR
+ ro ru sk sl sr sr@ijekavian sr@ijekavianlatin sr@latin sv th tr
+ ug uk vi zh_CN zh_TW"
+inherit kde4-base
+
+DESCRIPTION="PolKit agent module for KDE"
+HOMEPAGE="http://www.kde.org"
+if [[ ${KDE_BUILD_TYPE} != live ]] ; then
+ SRC_URI="https://launchpad.net/ubuntu/+archive/primary/+files/${MY_PN/-agent/}_${PV}.orig.tar.xz"
+fi
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 ~arm ppc ppc64 x86"
+SLOT="4"
+IUSE="debug minimal"
+
+RDEPEND="
+ >=sys-auth/polkit-qt-0.103.0[qt4(+)]
+ !sys-auth/polkit-kde
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+if [[ ${KDE_BUILD_TYPE} != live ]] ; then
+ S=${WORKDIR}/${MY_P}
+fi
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ # Coinstallability with kde-plasma/polkit-kde-agent
+ use minimal && rm -rf po
+}