summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-24 01:09:29 +0000
committerSam James <sam@gentoo.org>2022-11-24 01:09:29 +0000
commitc6dd328c2de4c30494d9c3ff28a6aa76dad48294 (patch)
tree8629033f210f1049b53a29f1c7d9962c652853c3 /sys-block
parentmedia-libs/libofa: fix configure w/ clang 16 (diff)
downloadgentoo-c6dd328c2de4c30494d9c3ff28a6aa76dad48294.tar.gz
gentoo-c6dd328c2de4c30494d9c3ff28a6aa76dad48294.tar.bz2
gentoo-c6dd328c2de4c30494d9c3ff28a6aa76dad48294.zip
sys-block/devio: fix configure w/ clang 16
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/devio/devio-1.2-r1.ebuild (renamed from sys-block/devio/devio-1.2.ebuild)15
1 files changed, 12 insertions, 3 deletions
diff --git a/sys-block/devio/devio-1.2.ebuild b/sys-block/devio/devio-1.2-r1.ebuild
index e726f3424a48..62241d9573f7 100644
--- a/sys-block/devio/devio-1.2.ebuild
+++ b/sys-block/devio/devio-1.2-r1.ebuild
@@ -1,12 +1,21 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-DESCRIPTION="correctly read (or write) a region of a block device"
+inherit autotools
+
+DESCRIPTION="Correctly read (or write) a region of a block device"
HOMEPAGE="http://devio.sourceforge.net/"
SRC_URI="mirror://sourceforge/devio/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 arm x86"
+
+src_prepare() {
+ default
+
+ # Clang 16
+ eautoreconf
+}